Urgent app help needed

Is it an acceptable workaround to put 2 bracelets on one phone till you solve this?

I really hope so! I’ll let you know.

Any screenshots from my phone worth posting to help resolve this?

Regarding 2 bracelets on 1 phone, the .pdf manual #4 mentions adding a family member.

Is Stay Home Safe stable enough at any stage to take a screenshot?

The activity of trying to take a screenshot at the point of failure might nudge you to observe any untested permutation, perhaps ?

A logcat would be the way to get to the bottom of what is failing, I guess.

No, not stable enough at any stage.

logcat - needs root, looks like.

There are different ways to get a logcat (and learn to do it efficiently !), if you can logcat as per the link, using a PC, I think this is a good point to start.

  $ adb logcat -d > logcat.txt

produces a very long output from last reboot.

I like to start an accurate clock and record the time of reboot and any actions I take. This helps identify the point to look for an error.

Notice how errors are recorded as E in a certain column. Ctrl +F (find) space E space helps find appropriate lines.

A rooted phone is not necessary.

  $ adb logcat --help

shows some more options (once the device is connected).

PS. Probably not connected, but I see that TrackerControl is complaining about 2 Microsoft trackers associated with Stay Home Safe. Might you have any other blocker which might have taken more radical action ?

I am testing on 1.5-q-20221031230909-dev-a3xelte, could it be significant your Android version, stable/dev and / or your method of Upgrade ?

1 Like

Thanks - the way you explain it, logging doesn’t look too hard, at least with my normal brain function. Something to try once my brain returns a little more, or if the workaround is rejected.

No blockers other than /e/. Same results with or without VPN

I’m running 1.5-q-20221031230909 dev “discovery”, and “pioneer”. Also tried on a third phone, 0.14-p-2021012698470 “santoni”. All of them continue to have the same result, on clicking to open app, first app screen opens then immediately closes within a fraction of a second. All phones installed the appropriate GmsCore.

Well, they are on their way up now. I’m alert enough to adb something now, but I don’t think there’s enough time before they get here.

Update: The workaround worked, so I get to quarantine with my family at home. Thank you!

I am very interestrd in finding out what the issue is with the app - it seems that a lot of apps in HK assume all phones can handle automagically altering things. I’ll make the logcat and post when I can.


@aibd I attempted a logcat today, but ran into my biggest problem with using /e/ in general - getting USB debugging to work is almost too difficult for me. Was at it for an hour without recognizing the device. I probably need to update the phone driver on the PC again. I seem to remember something about having to select the wrong model (XZ instead of XA2 Ultra) driver to get adb to work.

Any way to send you a log file directly from the device?

It is not really a subject I studied enough to guide you but when you search Settings > System > Developer options, within the sub section DEBUGGING is the setting Bug report shortcut, this puts a shortcut on the power button menu. There are other settings to experiment with …

Maybe this is a place to start

I have preferred the adb method.

@aibd I rebooted, clicked and tried to open the app 3 times, and then made a bug report. I’ve been looking through it, especially the E error messages, but haven’t found anything that I can relate to the problem. Should I send it to you?

I have to say that I am an amateur, I am not very confident that I would see something you did not see !

You might feel like redacting personal details from the report and uploading it to a pastebin service. I will be interested to have a look and maybe others will see something.

@aibd I’m not sure what personal details I should redact. It’s a huge file.

Maybe start at the top and make a note of anything connected with your name, IP, location, any other form of device or machine ID, anything else you can think might be sensitive. Then you can just Find and Replace those words or strings to obscure them throughout the file.

I remember a similar problem with my pioneer a year or so ago. I was trying to set the phone up using windows pc. The solution was to install a sony driver for the X in a specific way following this post by JJR: