USB Preferences are greyed out Fairphone 4


I recently got the Fairphone 4 and flashed /e/os on it. During the flash process no error occurred or anything like that. After I booted the os I could no longer access it with the adb.
The usb preferences are all grayed out and can only be changed via usb debugging and the default set.

It can’t be the cable, because it was recognized by the Fairphone OS without problems and I flashed the firmware with it. Is this wanted or actually a bug?

You need to re-enable Developer options after flashing as they don’t survive the flash.

Settings | About phone, then tap 7 times on the ‘Build number’ field.

Once developer options are enabled, you can re-enable adb debugging (and a whole lot more)

i know how to reenable the dev mode. And i read the instructions. The usb preferences are still greyed out. I know how to flash devices. Did you read my question? i dont think so…

Yes I read your question. I hope you find an answer. Goodbye :slight_smile:

1 Like

Two things

  1. Is a live usb cable connected?

  2. Please check default USB configuration.

A data usb-c cable is connected. With this you can set all settings on the fairphone os and can flash the device.

I had set the default USB configuration as I have already written in the usb debug settings. But i dont want a default settings. I want so selected it on the USB Preferences. It is greyed out. In the normal settings.

Hi, the same appeared here on a Samsung Galaxy A5 2017 freshly converted to e/OS/ build 20220728.

I changed the default USB configuration to « file transfer », plug the phone and it was in file transfer mode. But I also noticed the current USB Preference was no more greyed. So I changed back the default USB configuration to « any data transfer » and it work as expected now.

Hi, I’m facing the same issue.

The cable I used to make an adb connection is not working anymore, usb options greyed out, the phone is only charging, no data transfer. Additionally, the win pc is signalling an defect usb device, linux is not recognizing anything at all.
I’ve tried the FP4 is no longer recognized on Windows 10 / 11 via USB - #30 by gleu - Fairphone 4 - Fairphone Community Forum, but can’t access that solution
fairphone support is not helping me because of /e/OS :frowning:

I have tried:

  • various cables and all USB Ports on my computer. The phone only enters charging mode and I can't choose the type of usb connection on the phone (adb debugging is activated to no avail).
  • Resetting the USB Drivers on the computer did not fix the issue, my old phone connects just fine.
  • Linux is not recognising the phone either.
  • Tried a new cable in a store on their pc to which that phone had never been connected, same error.
  • USB restrictions under TRUST are not enforced

It seems to be a phone issue, software or hardware …
I have NetGuard installed, disabling it did not fix the issue (with reboot).
Advanced Security settings turned off to no avail (with reboot).

Oddly enough, a usb-C to usb-C cable is working on another computer (that makes a hardware error unlikely), but the computer I need to connect to only featurs usb-A unfortunately…

Any ideas? Thank you!

What gives Recovery or Fastboot, if available?

Hi smu44

Thank you for chipping in, and sorry for my late reply! I had some difficulties logging into the forum for a lost password and then got distracted…

What do you mean exactly by your question? The phone is not recognised with any but usb-C to usb-C, which I don’t have on the computer I need to connect to.

On the recovery screen, I can enable ADB, but I get the same error message on the computer, stating the last Device connected didn’t function properly and is not recognised :-/

You can also try to reboot the phone (to System), while plugged to the computer.