Using flashtool

I am trying to flash the firmware for Sony Xperia Z3 Compact “z3c”.

I have abd and fastboot installed, and set a path for them in active directory, and am able to access them from a command prompt. When I run flashtool and click on the lightning bolt, select flashmode, and select the folder where the downloaded firmware is, no files show up.
In file explorer I can see a lot of files in that folder (D5833_Customized SG_1288-5506_23.5.A.1.291_R3D), mostly .sin files and some .ta files.
Can anyone please tell me what I am doing wrong?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Using Flashtool :slight_smile: Flashtool is only used if you need to intsall the original Stock firmware from Sony.

To install the /e/ software, you need to follow the section called Installing /e/ from recovery on this page

1 Like

When I type “adb reboot recovery” in cmd, It shows “error: no devices/emulators found”.

Also, should I just assume that I am on firmware version 23.5.A.1.291? When I run the command adb shell getprop ro.build.display.id, I get similar error. “adb.exe: no devices/emulators found”

The device shows up in file explorer.

I think that what you are seeing means that adb cannot detect that a phone is connected. To check type ‘adb devices’. If it gives you no result, then either 1: your phone is not connected properly 2: you have not enabled USB debugging on your phone or 3: you don’t have the correct driver installed (assuming you are working on Windows).

If it is 3: then I don’t know how you should proceed: I haven’t used Windows in many years. DOyou have Xperia Companion installed on your PC https://www.sony.co.uk/electronics/support/mobile-phones-tablets-mobile-phones/xperia-z3-compact/articles/00236877?. If not, then install it and check your device is detected.

Last time I used flashtool Inoticed the same thing.

On the flashtool window select: Tools, then from the pop down select Create, then Bundle.

You will then be prompted to navigate to the firmware location and it should all follow on from there.

Watch this for a long but good video of the whole process…

Thank you Petefoth and Chrisrg,
I enabled debugging on the phone, and now adb can communicate with it. Running shell getprop ro.build.display.id shows that the firmware version is 23.4.A.1.232. It needs to be on on version 23.5.A.1.291.
I tried using flashtool in two different ways and neither one works. The first way was by clicking on the XperiFirm icon. A small window that says Running XperiFirm pops up and quickly disappears.
The second way was to go to XperiFirms website and download it from there. Then using chrisrg’s way using Tools, Bundles, Create. That way shows the files in folder list, but what do I enter for Device, Branding, and Version?

Follow the video instructions, just like I had to! More than once. :neutral_face:

I don’t know if I can ask this question here? Sorry, if not! I want to switch my Sony xperia 3zc (D5803) to / e /, but I have a message : … Could you help me please?

Thx

Sorry : the message :

Flashtool didn’t exactly behave like the video showed. In the video, creating the bundle automatically started the flash. For me, creating the bundle just made it so that when I clicked the lightning bolt, I was able to select my device and then click on the flash button in the bottom right corner. (Beforehand the flash button was greyed out.) However the 4 boxes that are supposed to be checked are still greyed out.
I presses flash anyway, and attached are the results.

Still can’t see any message :slight_smile:

The evidence of this forum is that people do help massively. But you have to ask the question first. At the moment your position is like, “if I marry you will you do everything I expect?”

To see if you are brave enough to start: read this and the page linked above by @petefoth and read all the linked documentation you can find.

Read the install page. Read it again taking notes on a very large piece of paper.

Now you can start playing with “What can do I before I start”. For this Sony, particularly understand the part flashtool plays in the process.

If you find you have a question to ask, consider opening a new thread perhaps including the ideas “switch my Sony xperia 3zc (D5803) to / e / - first time”.
You can generate such a post by clicking + New Topic from this search link. Please ask (telling us what OS is on the PC/laptop you are using) as soon as you find yourself drawn to deviating from the instructions, then we can guide you or make changes to the documentation!

Good luck :smiley:

I have a Sony xperia 3zC (D5803), n° build 23.5.A.1.291, i try to install /e/

1-adb reboot bootloader (OK)
2-fastboot devices (OK)
3-``fastboot flash boot twrp-``3.3.1-z3c-20200212.img : I have a message <waiting device> and i stop here and can not continu.

Have a nice day

Difficult to say and apologies if I’m wrong but it looks like you’re on Windows pc. Have you installed the drivers on pc that video shows very early on?

Creating the bundle and preparing for flashing takes most of the time with this process and the device should not be plugged in at this time. Are you plugging in too early?

In the video the prompt for plugging in comes at about 10.14.

It’s painstaking I know, but each step in video has to be followed for success.

@petefoth’s suggestion to try Sony companion is a good one if you need an easier route.

1 Like

Yes, I installed the drivers. Some of them failed to install, just like in the video, though I am not sure that they were the same ones.

I see now that I missed the step of selecting all the files in the folder list and transferring them to Firmware content. Now it won’t let me do it because a bundle with that name already exists. How can I delete the first one in order to try it again?

Does the Sony companion upgrade the firmware? From the description it looks like it only upgrades the software.

For windows, don’t know. On ubuntu I download firmware to a folder of my choosing. When creating bundle flashtool takes the firmware and sets it all up in .flashtool/firmwares folder in my Home directory. Here there are a zip and a torrent file of firmware which can be deleted if you want to start again.

I don’t know, never used it, but I guess it would update it in the process to the latest.

Thank you. On my Windows machine it was in there too. The firmware updated successfully.

I am having this problem again that adb gives the error: "adb.exe: no devices/emulators found”.
It is in fastboot mode (the blue light on the phone is on), adb devices doesn’t show the phone.
Fastboot shows the device.
The cable works to transfer data when the phone is on.
USB debugging is enabled.
In device manager it shows the driver is installed.

What could be causing this?

Never mind. I forgot that for adb to work, the phone needs to be on, not in fastboot mode.

1 Like