Very late notifications from Signal


I receive Signal notifications very late or only when I open the app. It was working correctly with the stock ROM.
However I receive notifications on time on my linked Windows PC.
Is there anything I can do?


Please check the Batterie setup for Signal. Under App Info / Batterie should aktivated ‘Don’t optimise’
This should be done for every up with push notification


A bug has already been raised for this

1 Like

I think those are different issues. The verification code at installation time is send as an SMS (to verify the phone number). @anata asked about normal messages which most likely has to do with push notifications. This could be testet: do messages arrive faster while Signal is open?

Yes, different issues. Message arrived quicker and now that I configured the battery optimizer it seems to work correctly.
Thanks for your help.

@anata and @hex-m thanks for the updates.

The issue still exists even without battery optimisation for Signal. It just happens less often or maybe I notice the issue only when I use the web app at the same time. I don’t know if it’s really linked.

Is there any else I can check?

What do you mean with 'if it is really linked? ’

Have you checked under notifications in.system setup and in Signal?

Sorry, picture upload fails from my phone :thinking:

On the signal website there is a long list of recommendations in order to troubleshoot notifications: An additional action I found on that web page is:

Enable background data.
Android phone Settings > Data usage > Data saver > If data saver is disabled, stop here. If data saver is enabled go to Unrestricted data access > Enable Signal.

I meant I wonder if there is a link between the usage of the web app and the late notifications. I didn’t find anything interesting in the notification settings or in data saver settings :confused:

I noticed What’s app is also impacted.

I think most push message apps are involved.

Do you think it’s due to LineageOS? Or /e/?
Should I raise the defect on

It’s because of microG and the issue is known, No need to create a new issue on gitlab.