VLC installation failing: "this app isn't compatible with your phone"

Like it says, I’m trying to install VLC, and it’s failing. The error message is “this app isn’t compatible with your phone”. I’ve tried installing from /e/ Apps, F-Droid, and downloading from apkpure.com. All produce the same error. I wonder if it’s an arm vs arm64 thing? I dunno. I’m Linux savvy but this is my first experience with an alternative phone OS. Everything else works beautifully, very very happy with /e/ on this phone!! This VLC install is literally the only thing I’ve run into trouble with. Thank you for any ideas on this.

My phone is Samsung S4 model SGH-M919 running /e/ 0.7-2019122535327 Android 7.1.2

Could be that it has something to do with your phone hardware as I’m running VLC without any issues on Android 8. But Anroid 7 should also work without issues as the minimum required Android version for VLC is 4.
What is the VLC player version you are trying to install?
From where are you opening the .apk? Directly from the file manager or from within F-Droid? Is the specific app able to install from unknown sources?

Version is 3.1.7 from /e/ Apps and F-Droid. It’s 3.2.6 from apkpure.com. Installing from within /e/ Apps or F-Droid results in an “Installing…” step that continues indefinitely and never completes. So I tried installing directly from the file manager, from the Downloads folder. Yes I have “install from unknown sources” enabled, and I can successfully install other apps the same way. VLC is the only one that’s failing with this message.

I should add that the first time I attempted to install VLC, I thought it had hung and I force quit the ‘Apps’ app. Is it possible that VLC is partially installed i.e. in an inconsistent state? Is there a way to get into the OS filesystem to manually check & remove all traces of a failed app installation?

Downloaded and installed 3.1.7 from /e/ Apps Installer and it is working ok.
Screenshot_20200108-073735_VLC
Can you try downloading the apk from Aurora Store and check if you are able to install it.

Installed apps should show up under
Settings >> Apps & notifications >>See all apps ,
Pl check if you can see VLC there.

… on Samsung Galaxy S6 Edge

VLC is not visible on the list under Settings > Apps.

Just tried installing VLC 3.2.6.13020604 as offered in Aurora store. I get the standard prompt “Do you want to install this application? It does not require any special access”. I click on “Install”. So far, everything is the same like /e/ Apps and F-Droid. But this time it finishes successfully! And I can run it and it works!

Not sure what’s different about VLC from Aurora vs. from /e/ Apps or F-Droid.

Could be an issue with the version number - the FDroid version and the App Installer versions are old compared to the Aurora Store version.

As a test, I removed the VLC that came from Aurora. Then tried installing from F-Droid. That worked! Installed successfully and it runs.

Next tried uninstalling VLC from F-Droid, and installing from the /e/ Apps store. No go. It’s been at the “INSTALLING” status for 15 minutes now. Checked System > Settings > Apps and VLC is not listed.

Next rebooted phone and tried install from F-Droid. It worked. Installs and runs.

Same issue, S4 (https://gitlab.e.foundation/e/apps/apps/issues/18)

Wow, exact same thing, so it’s not just me then. Must be a device specific bug?