VoLTE / WoWiFi problem in Android stock FP4, could switching to e/OS solve it?

I am experiencing a problem on my Faiphone (Android stock), relating to the configuration of the VoLTE.

In particular, when VoLTE and WoWiFi are active, I cannot answer to incoming calls on 4G network and VoWiFi. My mobile side I answer and the call ‘starts’, but the line drops after about ten seconds. Caller side continues to ring.

My operator (Very Mobile / Wind3 in Italy) is not one of the certified operators (but there are no certified operators in Italy). In my previous devices (also not certified) both VoLTE and WoWiFi worked properly.

I assume the problem is related to the VoLTE configuration.

If I were to install e /OS, would the VoLTE configuration part be different?
Would I have any hope of solving the problem?

In all previous devices (even non-certified ones) VoLTE worked for me without any problems, so I assume it is a Fairphone-specific problem.

I think it’s recommended that all function are working on the phone before installing eOS. I ran into a similar issue with a OnePlus Nord.

Check you APN setting in the stock ROM for your carrier. Also is the ROM in that phone up to date or is it offering a firmware update?

APN = Access Point Names.

In setting use the search box and type in: APN