Waiting for any device → installing /e/ on FP4

So, I am trying to install /e/ on FP4 but I have some issues on the beginning. I get to the bootloader, but I don’t see any devices with fastboot devices. If I try fastboot flashing unlock I get <waiting for any device>.
And adb devices returns in the ID of the device and “device” as a name of the device.
I use Fedora 35 and I managed to flash /e/ on FP2 last year and it went smooth.

Anybody has any idea?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Worth a try: Search results for 'fastboot waiting for any device fedora' - /e/ community

You have to do "sudo fastboot ‘command’ ". I use Fedora as well and it’s the only way I can get fastboot to see my devices.

Thanks for your fast reply. I tried sudo, but I still get < waiting for any device >

I installed android-tools from Fedora repository.

… and you know that you need to be in Fastboot mode for fastboot devices to respond?

1 Like

I think I am. With command adb reboot bootloader I get to the FastBoot Mode, with all the infos (PRODUCT_NAME, VARIANT, BOOTLOADER VERSION, etc.) and a big green START on the top of the screen.
Am I missing something?

You could still try the current Android SDK Platform Tools.
It has been found time and time again that this can make a difference compared to what Linux distributions offer.


Hi @lapor, … you are probably aware of this but … while troubleshooting it might be a good idea to leave your /e/ install instructions on one side and explore the bootloader with the hardware buttons as described under “hidden modes” on this page Hard Reset FAIRPHONE 4, how to - HardReset.info.

Then you can use the commands

adb devices
fastboot devices

just check you have contact with the device. You could also check your versions with

adb version
fastboot --version

If you decide to use imported platform-tools should your Fedora “System” tools prove unsatisfactory, take care to direct your commands very accurately, or be sure to fully uninstall the “System” tools.

1 Like

Thanks for all the help. My version of android-tools is 31.0.2. I will play with it a bit more in the afternoon. when I’ll have some more time.
I get correct info with adb devices, but nothing with fastboot devices.
You think that it would work, if I hard reset the phone before I try the fastboot magic?
I did try with the newest platform-tools and the ./fastboot devices, but still nothing.
If all fails, I’ll try on some other computer. I’ll be back in the evening :nerd_face:

I would not really expect a hard reset of the device to be significant, but I guess you could try. The PC, USB hubs, front or back ports, the cable itself are all involved. It has been known to have 2 way transmission with adb but fastboot fails for any “unlucky” combination of the above!


Thaks for all the time and help. I played with some cables and one worked (usb-c to usb-c from pine 64). It was odd, because file transfer and adb worked with previous USB cabel (usb-a to usb-c).
Well now I have /e/ once again.


Just to say I was facing the same issue with my FP4 and MacOS, I had to try several USB cables before it worked.
Even though adb could detect my FP4 with any cables, fastboot could detect my FP4 only with one of the 3 cables I have.

1 Like

As I did have the same problem, and my solution is not mentioned here, I just wanted to leave a short note.

I did get correct info with adb devices , but not with fastboot devices . I did try 3 USB cables in 3 USB ports but did not find the “magic” combination.

In my case it helped to reboot the bootloader from inside the phone’s menu, not from the PC via ADB. If you are in the FastBootMode, usually you do have the green START on the top. If you press volume up (one or two times) it will change to reboot bootloader. Then press the start button. After that it worked for me.