*waiting for any device* issue when installing FP4 -> SOLVED

I had an issue while installing /e/ on the FP4 using Windows 10.
The Phone was recognized in adb mode but not in fastboot mode and the following message appared: “waiting for any device”.

Luckily I found a solution which I want to share with you:
This was an USB driver problem, therefore I had to update the driver in Windows 10.

  • I went to the Driver Manager, there the device was shown in “USB-Devices” as “Fairphone” in adb mode. When I switched to the bootloader the device was shown in “Other Devices” as “Android” with a yellow triangle.
  • While the phone is in the bootloader, right click on the device (Android) in the Device Manager.
  • Choose update driver
  • Choose Search automatically for updated driver software → Windows doesn’t find any drivers
  • Choose search for actualized drivers on windows update
  • Choose show optional updates
  • click on driver updates
  • I updated three different drivers (LeMobile Android device and two others)
  • After that my device was shown in the device manager under LeMobile Android Device with the name Android Bootloader Interface and the the device was shown in the PC-console when I typed fastboot devices.
  • Furthermore the installation worked fine in the PC-console that I have started in the Folder with the .img files.

Good luck!

1 Like