WARNING Unusable and Useless DNS (and few other settings...)

Teracube 2e /e/OS 0.20 Android 10

The DNS tweak is Unusable and Useless when I configure and check at it show that I’m NOT connected DoT

Icons form settings are useless and unusable and do not work

Weather widget is scrap with erratic temperatures but we can not delete it … useless and unusable

We bought a FREE degoogled device but we are not free to use freely… its odd

cloudflare DoT DNS is not
It’s one.one.one.one

In fact its 1dot.1dot.1dot1.cloudflare-dns.com

Anyway this do not work on android 10 /e/OS 0.20 build Teracube its useless unusable option

Are you applying this in the Private DNS option in Network Settings? I don’t have android 10, my phone’s on 11 and it works ok.

Weather widget is controversial and the forum is full of discussion on this but don’t forget you are free to install another launcher. Give it a try and take time to get to know the settings of whatever launcher it is; it takes time usually to fully grasp the possibilities.

As I said all private dns options applied this DO NOT work. DoH work, DoT do NOT work. (teracube 2e /e/OS 0.20 build)

Ah sorry, I misunderstood; I thought you were looking for a bit of help.


1 Like

My phone is on 9 and works, bug in 10?

Yes you misunderstood I do not looking for any help and there is nothing you can do… me too… its just a shameful big bug from /e/OS developers as I said in title its a WARNING for users

Yes may be I don’t know but it is

Did you leave the flip-switch enabled on “Use network DNS”?

Because all other options resulted in DoT queries for me.

I think it is a bit confusing that you can set a DNS ip manually a few options up in the Network Settings, then there is a button to set a private DNS hostname further down below the dropdown. Either set to automatic or enter one.one.one.one - but have “Use network DNS” disabled.

1 Like

Its a /e/OS 0.20 android 10 Teracube 2e BUG, there is nothing to do about that

If that work with your device you certainly do not have teracube 2e with 0.20 android 10 build

We already tried all possibilities with Thilo from support without success its a bug

As I said I do not looking for help it was just a warning for users

You could consider to volunteer to the test team to improve the Teracube device support.

1 Like

Yes sure this is why I paid for installed /e/OS phone

1 Like

You are aware most of us are volunteers right?

1 Like

Yes. Me too. I voluntarily choose this phone, and voluntarily paid to use it 8-))

EDIT: For info DoH and DoT work only with stock web browser actually but still not work if you use any other like Brave Edge etc. Any private or automatic DNS configuration stay obsolete unusable and useless if you do not use stock web browser

If you consider it “Unusable and Useless” then return it to /e/ and ask for your money back.

Moaning about things you see as shortcomings in a community forum (and a community support Telegram channel), in a way that comes across as aggressive and confrontational, is a good way to ensure that people who may be in a position to help (although you are not looking for help yourself, you are only trying to “help” others) will choose to set your status to “ignored”* so they don’t have to put up with your complaints)

(* To set a users status to “Ignored” in this forum, so their posts are hidden in your view of the forum, click on the Users name then click again on the popup that appears. That will display the users Profile page - e.g. Profile - janolapino - /e/ community. Select the lower button on the top right of the page, then choose “Ignored”.

Telegram also has a useful “Mute” button which has much the same effect. Goodbye :slight_smile: )


uh, no offense taken. Firefox uses the system dns too, not only stock Bromite. I gave Brave a try (admittetly with an Android R), and if system level dns setting is proper, Brave uses the encrypted DNS. I wonder what is wrong. We would need a teracube2e user to confirm, but mostly the builds have the same issues within an Android version for that type of Bugs

The forum sorts out usability problems and bugs. If confirmed it will find its way into the bugtrackers. There are some secure-dns issues, but nothing that fits your problem directly imho:


Well you know I just post a WARNING which mean I do not look for any help nor moan like you who seem to be not understand its may be the same with your own device - because YES DNS configuration are obsolete unusable and useless -

But before you banish me I’m pretty sure you was eager to checked your device hypocritically to tell me now that I’m very ugly person bla bla blah … and that tells us a lot about you petefoth so I can say I’m proud if you do banish me Thank you !

1 Like

Sorry that the phone you purchased from /e/ does not meet your needs. Pl send it back with the purchase details and I shall have the team arrange a refund for you.


Its a question Manoj ? If this is a question yes eventually I will see with the sale Dpt for any refund if this issues are not fixed soon… I will not discuss here with you about shipping back fees (I’m in north America) or penalty nor purchase details…This device is supposed to be updated often so wait and see for now. Thank you.