Webdav on Linux

Hello everybody. These last times I can no more get /e/ nextcloud in my Linux desktop, not with Dolphin as webdav nor as partition with davs.
Or rather: I can wirth Dolphin, but every time, unlike in the past, I have to provide user and password.
And in with davs, even following these steps I can’t mount nextcloud, I get this error message:

Could not mount device.
The reported error was:
/sbin/mount.davfs: Mounting failed.
302 Found

Thanks for your help!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Why don’t use the nextcloud client for Linux. It works out of the box

Thank you. I didn’t ever used it. Uhm… another program… The less new apps, the better, I think…
At that point why not use the browser?
Moreover: why once nextcloud worked as webdav, and now no more?

Which address are you using?

To create a Dolphin entry: webdav://ecloud.global/remote.php/webdav
This works, but it requires always the user and password…

Ok, there was a way to ‘send’ it via command.
Best you would search the web for the solution


Worked and then no more… smells update I think.Perhaps try a full-upgrade and if don’t solves issue install -t backports’ version (if exists)…

thank you. I will try.

But maybe, as seems suggest @harrvey186 adding at the end of webdav://ecloud.global/remote.php/webdav user and password could world? The problem is the right syntax, I think.

I will search on web.

Yes, something like this. It’s to long ago that I have to use it. So I have forgotten :frowning:
Could be, you will an answer in nextcloud docu

1 Like

Reviving this old thread because I have just gone through the pain of working out how to mount my eCloud in Linux and thought I had better document it before I forgot.

This method uses systemd to automount the eCloud on a directory when it is accessed. It should work with any desktop and file manager.

First install the davfs2 package using your distro’s package manager

next create a mount point in your home directory
mkdir ~/eCloud

Then create a file (as root) with
sudo nano /etc/systemd/system/home-USER-eCloud.mount where USER is your linux user name


Description=Mount WebDAV Service



(Replace USER with your user name)
(uid=1000 assumes your user id number is 1000, change it if it is not)
It is essential that the name of the file matches the path of the mount point.

Do not enable or start this systemd unit because this unit will be triggered by the next unit we will create

sudo nano /etc/systemd/system/home-USER-eCloud.automount

Description=Mount WebDAV Service



next we have to save the login credentials
sudo nano /etc/davfs2/secrets
Add a line

/home/USER/eCloud “YOURMAIL@e.email” “YOURPASSWORD”

USER is the linux user
YOURMAIL is your /e/ email
YOURPASSWORD is your /e/ password

I found that davfs would not work through my VPN so I had to route davfs around the VPN using a proxy server. I have privoxy running on another computer. To use it simply add another line to the secrets file YOURMAIL@e.email

(replace with the host address and port number of your own proxy.)

Next we have to edit a file
sudo nano /etc/davfs2/davfs2.conf and add a line

use_locks 0

Now enable and start the automount unit
sudo systemctl daemon-reload
sudo systemctl enable home-USER-eCloud.automount
sudo systemctl start home-USER-eCloud.automount

Now the moment of truth. Browse to your /home/USER/eCloud folder using your file manager, and click on it. Hey presto your eCloud file system should appear. Hopefully…

If it does not work use journalctl -r to find error messages.

Hope someone finds this useful.