Webdav setup not working with 2FA enabled

I can successfully setup a webdav connection to my Murena cloud file storage inside my local filemanager (Thunar) on my Arch Linux installation. However, when I enable 2FA in my Murena account, it doesn’t work anymore. I get a authentication error, and there is no way to enter a new password, for when I would create a specific app password in Murena cloud security settings. Also removing and re-adding the connection doesn’t make a change. If I disable 2FA it works again. Should this be able to work with 2FA? Is there a way to make it work?

For WebDAV you will have to bypass the 2FA with an app password. Look at the section “Using an application password for the eOS account manager” in the 2FA documentation and just replace the account manager with your WebDAV application.

1 Like

@ljahn Maybe it wasn’t clear, but I already tried setting up an app password. It doesn’t prompt me for a password, so I can’t fill it in.

Well, I’d say if Thunar doesn’t prompt for a password when setting up the connection again, there definitely was some config left where it is taking the old password from.
Do you have any “system wide” integration of this account enabled (as offered by GNOME or KDE)? Maybe it mathches the URL and gets the password from there.

I’m trying with another file manager - Double Commander - but I get “HTTP Error - Unauthorized”. Should this really be able to work with 2FA enabled?

Edit: Also just tried with Nautilus, exact same error message.