Week 25, 2022 : Development and Testing Updates

Hello, after my OnePlus 8T mobile phone was updated to 1.0, the fingerprint has expired, and the display fingerprint hardware is not available.

Thank you for the update.
Not sure if I read this correct.
Can you confirm that the mobile data issue of S7 with v1.0 is also adressed?
(It’s not explicitely mentioned but part of a linked thread…)

I am assuming you are referring to this issue. This has been shared with the build team. Will update on the response.


There is a report of this issue here Pl add your issue details to the same bug. That way the developers can check on it and get back to you for clarifications.

For help with raising issues, check the /e/OS links section above


This is rather unfortunate, seeing that support for Pie has ended.

1 Like

App Lounge has been acting strangely: Continues show an update for NextCloud and after downloading it, trys to install it and reports the need to retry. This just keeps cycling. Tried to force stop App Lounge and now it won’t successfully open, even after poweroff and power back on.

Is this the place to report this?



Actually I haven’t been able to open Applounge at all in the last couple of days, although it had been working fine befor. It just keeps stopping. Samsung Galaxy S7 with /e/OS1.0-Q

App Lounge crashes upon startup
Workaround: “Clearing cache and all app’s data”


It’s good to see that the FP3 appears at least somehow regarding the OTA upgrade schedules. But Android 9 EOL’d on january 2022.

The unknown ETA is not a good sign for me when seeing the dropped support for Android 9. Guess I’ll be stuck on Android 9 until somewhere in 2023? :frowning:

If you want to wait for the OTA upgrade that seems like a plausible guess.

But Android 10 and 11 beta as well the Easy Installer are available for the Fairphone 3/3+. That’s a situation not every /e/OS device is in.

Seeing that an upgrade requires wiping the phone: Is there any viable (non-root) solution for backing up the device data?

Thanks, that solved the problem for me, too :slight_smile:

There is no one-size-fits-all solution. There are different possibilities and approaches which can be considered for different user needs and situations.

It starts with copying the Internal Storage to a computer via USB.

Then there are tools like MyPhoneExplorer, adding connections other than USB as well as handling of contacts, messages and more.

It gets tricky when it comes to Apps and their data. Here’s something recent …

… but TWRP needs an unlocked bootloader on the Fairphone 3/3+, Seedvault isn’t available in Android 9 I think, and ABRT needs Rooted debugging which is currently not available in stable /e/OS builds, only in dev.

Thanks to Android’s basic negligence in this field, backup is a vast and at times depressing topic … https://community.e.foundation/search?q=backup


That works! I tried this before I commented the first time, but it didn’t work. Doing it just now did work. So, things are spinning back in their groove!


The only “foolproof” solution I have found is - sadly - Google’s own Backup functionality, which backs up apps and data to a user’s Google account, and allows it to be restored during first-time stetup of a new device or new software. That has seen my wife’s phone - running LineageOS with GApps - through regular updates, and OTA upgrade from LOS17 / Q to LOS18 / R

Thanks for your thorough reply! MyPhoneExplorer is unfortunately only available for Windows and I’m running Linux, so that’s a non-starter, I’m afraid. Is there any way to leverage adb on Linux to make full backups?

I think I’ve seen mentions of it working on Linux via Wine, but then only with WiFi connection to the phone, not USB.
Else you could have a look at what KDE Connect can perhaps do for you, it sounds like it could be something similar on Linux, but I didn’t look into it myself … https://kdeconnect.kde.org.

If Settings - About phone - Android version (tap on it) - /e/ version says you run a dev build, you could activate Developer options if not done already to enable Rooted debugging there to then have a look at ABRT mentioned in the post I linked to.

Beware that the tempting adb backup command is deprecated and restore doesn’t work reliably for everybody.


I use two ways.

1. Backup with tar:
This is for extract different files from data.tar later.

adb shell tar c -C /$PARTITION --exclude=lost+found . > ${PARTITION}.tar

2. Backup with partition-Image:
This is for full-restore.
For this take the Phone to Recovery-mode with activated adb.

BLOCK=/dev/block/sda18     # for Samsung S7 edge
adb pull $BLOCK $IMG

I do backupimages from data, system and external_sd.

It is better to create your own thread for further exchange on this.

1 Like

I do have a FP3+ and updated to e OS Q 1.0-20220526188859-stable-FP3 in May. Since today it shows a new update to “1.0”. Did anyone else have that and try it? Is it an error or something like “1.01”?

/edit: Found the answer: V 1.0.1 FP3+ fixing problems since v 1.0