Week 39, 2023: Development and Testing Updates

Hi @piero, technically how do you proceed to flash the BL and CP part of the firmware with the e-recovery as is not propose “flash” button in the main menu, maybe in “advanced” menu ?

no, use Windows Odin.
or untar the .TAR files and flash the included .IMG files using Linux Heimdall

1 Like

I suppose if you have the lastest e-recovery on your phone this point should be OK. Can anyone confirm this ?

Update 28 Sep: Some builds are still not complete or may not be showing up on the images server. This includes /e/OS T builds and recovery files. The team has been informed about this and is working on resolving the issue. Shall update on the progress.


Pixel 4a Sunfish [e-1.15-t] appeared an hour or so back, but there’s no recovery listed alongside.

Will there be a T specific recovery or can the [recovery-e-1.14-s-20230819321663-dev-sunfish.img] be used?


Same story with the OnePlus 9 Pro.

Wanted to update that the team is still looking at the issue of the missing recovery zip files.

Meanwhile some users are reporting that the sideload of the T build was successful. Getting more details.

1 Like

Made the system upgrade to e_star2lte-user 11 RQ3A.211001.001 eng.root.20230915.083737 dev-keys
Samsung Galaxy S9+
Everything seems to work

OnePlus 8T is also still missing the recovery image. Unfortunately; I do not think it is possible to flash without it, because it needs additional partitions.

Hope the missing file will be available soon, have been eagerly waiting for /e/ T for quite some time.

Thank you!

Will devices for which non-OTA upgrades to T are released still get OTA updates to S?

If so currently, then not indefinitely.

Strange issue. Both my Samsung S9 + units upgraded to 1.15. One now shows 1.15 is ready to download. Very strange. I refreshed my other device (many times), but no mention

of 1.15 download.

Note the dates.
According to your screenshot the build you already installed is from “14 September”, the one offered for download is from “15 September”.
So, apparently there was a new build one day later.

Also seen here … Feedback for v1.15 - #63 by mw0

Did the other device install the newer build already?

Question is: Can I wait for an OTA upgrade or won’t that happen?

Good spot. The other has the later build. I just looked at version number, but if a newer one, shouldn’t it be 1.15.1 for clarity.

Not necessarily if there was no change in content. It seems for some reason the system producing the builds was run again.

Thanks for the information.

If you have a device on a ‘stable’ build then you might get a OS OTA Upgrade. If not then you need to upgrade manually.

Check the link I have posted above for Fabrizio, if you don’t know if stable or dev.

For xz2c no recovery was listed for 1.15, either S or T. I updated OTA successfully from 1.14 S to 1.15 S without any apparent problem, and updated to 1.15 T manually. Will I need to go back and update recovery when and if one appears for 1.15 T?