What could be the reason that an unused app is unstopable and not as unused deactivated

Perhaps Safe mode first – this will help identify if

  1. system apps are responsible
  2. one or more installed apps are causing the drain.

ok I’ll give a look.
thx for the tipps. :+1:

really strange… as we talked about the how to next for 3days. I reduced the notification possibilities in app-settings, and the one by system regarding the app which make problem.
Then I deleted the cache of it and forced it to stop.
That was fully satisfying during 1 & 1/2 days, the other 1 & 1/2 days till now, it make the same game again, and take a lots of ressources.
This time is the app itself and unstoppable, i don’t know how it wake itself gain, and the Phone inactive process which take the ressources. not the wakelock this time, but advance privacy something more…
What male me nervous is the app which is unstoppable, and system do nothing against it ich take a lots of ressources…
next step will be the safe mode as you recommended…

I’ve found an other setting in which i didn’t paid attention until now which is directly by system-settings/application/all app/the app/ remove autorisations et make space free (translated from french).
I deactivate it now, and load the phone an observe it…

If I am not mistaken the Samsung watch app does not generally work on custom ROMs and probably less so on a non-Google setup.
Keeping an app that cannot be used and is causing problems doesn’t seem to make much sense.

That said, there is a post here with a method to get the app (Galaxy Wear?) working without root.
Maybe see if it will work for you.

Thank you for your answer.
at first that’s not the app for samsung, but for the matrix powerwatch 2.
The watch is pretty cool, but seems that some parts need to be updated side app and watch
It was maintained actively until last year, was a small update at the end.
matrix still exist and seem to be active but with low effort.
Side Powerwatch seems nothing to be active, and developper don’t reacts to any mails…

That’s a pretty nice watch which hold on battery by me over 4 months without recharging…
It’s little bit buggy that why, get an other one more “well known”" and good maintained with good autonomy, but not the huge autonomy like by powerwatch.
I give sometimes a look on it, for comparing or for special outdoor activities (watch is more strength)…
And I haven’t an old phone, where i may better use it with this watch…

Don’t know in this case if the adb solution could help…

1 Like

… but the uninstall option will save much time, will clear storage by default, and can always be reinstalled.

yes indeed, that’s currently the easiest way to handle the issue.

Don’t know why the system don’t detect it as unused and park it like this?
or isolate it by this weird behaviour?
or don’t give the possibility to make it as unused manually?

What’s happened by uninstalled ? all my data exchanged with the watch are definitivally deleted?
Or is that only the app ones, and the files related to my activity remained and are usable for next install& use?

Apps (especially if they “seem to be active but with low effort”) may turn weird after time and easiest thing is to uninstall and reinstall. I have to admit this is the basis of my answers even though your title asks

What could be the reason that an unused app is unstopable and not as unused deactivated ?

The answer to this question probably involves creating a log, learning how to read it or send it to the developer.

Almost certainly yes.

Are you using the version of Matrix PowerWatch with the name com.matrix.powerwatch (although I see you mention “matrix powerwatch 2”) ?

If yes,
You might first use Files app to search internal storage > Android > data > com.matrix.powerwatch

here you may find the data that has been saved by the app. You could make a copy before uninstall the app.

If the copy is returned at a later date, the newly re-installed app might regard it as valid.

Alternatively does the app contain the ability to export data ?

This link https://play.google.com/store/apps/details?id=com.matrix.powerwatch&hl=en_US does include a developer contact section.

thank you for the creating log part.
And for the app data part to backup, i’ll give a look on it.
Yes that would be the next point to install and reinstall it.

Regarding the app on googleplay, n that’s for the version 1 the one that i use is this
for the v2 generation.

I’ve already try to contact the matrix, but since 2021 no more Response and their zendesk is now closed.
Tried now direct from their website again:
i’m curious on how they answer, if they answer…

PowerWatch 2 also known as powerwatch.matrix.com.pwgen2android will keep its data files on the phone in
internal storage/Android/data/powerwatch.matrix.com.pwgen2android.

I did succeed in installing and uninstalling the app from App Lounge, I did not login / create account, but noticed no odd behaviour.

I’m still not ready with app uninstall or system safe mode.
I’m just observed how it works since I reset the option from system about the app system-settings/application/all app/the app/ remove autorisations & make space free. Then after it force to stop the app
Strange is now the app seems really to be stopped, but now is the “phone inactive” with “os android” and wakelock which eat the ressources… I didn’t restart the phone, and I think it will do the trick, because a kind of work between the app and the system is on working and system is waiting of the app.
But somehow the system didn’t learnt that the app stopped, and works further with

Is that possible to generate a log file without an adb host with pc?..

argh! should wait till this evening, I can’t do it on the current one…
ideally would be on the phone itself without further pc…

thx anyway :+1:

thanks for the howtos links, there is one to generate a log without pc too.
But now I have, and look inside… have no clue to understand or identify the problem inside…

That was my intention: “[HOWTO] Create a log (a bug report) easily without computer” – I adjusted the format to title only, rather than the in line format I initially used. I guess you accidentally touched the “You will find some HOWTOs here” rather than open the intended article :smile:

You might send the report to the app developer, if you thought he would reply ! :slightly_smiling_face:

I gave some “getting started” clues in this post Boot loop on Galaxy S9 related to checking SD card - #8 by aibd

there i 'll get no answer. I don’t know if the app still make the os mad.
But the os by me has a behavior that’s weird. thus want more give a log to the eOS team
for having a look on it

thanks but I didn’t find anything that it would interest me.
A lot’s think and errors are cryptic. I would need more a parser and an interpreter for the things that i’ve no idea on what it’s talking about…

I don’t know where for eos team I could send it, if there is a issue ticket system, or they pick the stuff here by community system…

Issues against the /e/OS system itself are filed here https://gitlab.e.foundation/e/backlog/-/issues.

There is guidance on reporting an issue with the /e/OS system here https://doc.e.foundation/support-topics/report-an-issue.

Open the log in a text editor and just use Find ( ^F ) looking for Errors _E_ that is ‘space E space’.

As explained by the following order of severity, many lines do not concern you so check for Error.

V: Verbose (lowest priority)
D: Debug
I: Info
W: Warning
E: Error
F: Fatal
S: Silent (highest priority, where nothing is ever printed)

It’s not that easy to track, now the system tells me that the privacy app use the whole system ressource.
like the other app before, seems that the activity of the app not correspond with the system info…
really strange.
I try to to load the phone to 100% wait till 10% and make a report…

Hi also since last post I’ve de-installed some apps that I didn’t use, and update with the eOs v1.13.
Now the battery use is something better, acceptable.
Don’t know why, in v1.13 changelog nothing in mentioned around it…

This topic was automatically closed after 89 days. New replies are no longer allowed.