WhatsApp calls/video calls are muted just for me (GSI Rom)

Hi, anyone having problems using the WhatsApp calls (please don’t come here with the whatsapp bad thing, i know it but sometimes you have to use it, for work and etc.)
So here it follows:

-My mic and speaker are working fine everywhere else
-Mic on call is not muted
-The other part can hear me speaking but i can’t hear them back

Any help? Does anyone have any solution?

I have the same problem with my Fairphone 3.
What’s the model of your phone ?
I haven’t found a solution yet. I’m hoping that someone will be able to help us.

1 Like

Moto G6 Play (aljeter)
This would probably make me uninstall /e/ as my next step, cause unfortunately i need to use this…

The strange thing is that the mic and speaker works everywhere else, so one might think is a WhatsApp problem, but then it just happened to me on /e/, so i would really appreciate some help, if there is.

Everything there is permitted for WhatsApp. Still not working.

I have the bug report in casy anyone understands this (cause i dont, lol)


Hi @hrqmonteiro I have been using Whatsapp to take calls from some of my ex colleagues who are now based in the US. Long 30-45 minute calls and never had a problem. This on the official pie build for tissot. You should raise this as a bug. Also mention you are using a GSI image not sure that should impact but any detail will help.


Thanks @Manoj, i just submitted. I hope someone can come with a possible solution.
I understand that GSI is not official, but so far it is still the best rom i could find to have a ungoogled experience, so i really wanted to keep this as my daily use rom.

Have you solved this?

Hi, I’m having the same problem - Fairphone 3.
Hope a solution is on its way…

Hi. Same issue, no sound received with whatsapp. Another strange thing, is that for skype (another bad app but compulsory for work :/) it is the opposite: i hear but correspondant cant hear me…
Any issue welcome, just to flag the issue again.

Auto replying as i found on this forum the answer: update of OS /e/ needed to be done and issue fixed!

I believe they finally gave the attention needed to this issue, i’ve been seeing on the Gitlab, but not because i flagged it, but because it happened too on the Fairphone

But now, apparently, they did an update and solved the issue for them, but, bad for us is that the GSI rom has no support at all, so no solution. I simply dropped /e/ and returned to LineageOS. Is impossible to have a daily use without Voip calls on business, unfortunately.