Whatsapp can't download things anymore

Hello together,

first of all, thanks a lot for all these useful things in this forum. I use /e/ since 3 weeks now and I’m totally happy with it!

About myself, I’d say I’m a mainstream user. I had an iPhone, then bought a Volla Phone but didn’t like it and then got myself a Fairphone 3+.

I know, Whatsapp isn’t good at all, but I tried it without it and it just didn’t work out (university groups, work group, football,…).
Since today, I’m not able to download things anymore. That contains pictures and voice messages. It doesn’t work for me to take my own voice messages, too.
Error at pictures/trying to play voice messages: Download failed.
Error at trying to take a voice message: Could not set up the recorder.
What I tried:

  • reboot
  • reinstall from different sources (Aurora, /e/ Apps, Apkpure)
  • controll the permissions
  • manually delete the Whatsapp folder on my sd-card
    What I use:
  • Fairphone 3+
  • SD-Card from Samsung
    What works:
  • I can take pictures in Whatsapp and they’re saved to the SD-Card, so there seems to be no problem with the permissions
  • every other app can read and write on the SD-Card
  • Whatsapp Web: I can see every picture and play every voice message.

Anyone an Idea? This unfortunately is a very important app for me.

Thank you,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Update: Just tried it with Telegram, there’s exactly the same problem. Signal works fine for me. Very strange; Telegram is the FOSS version from FDROID, Signal is from /e/Apps I think.

Did you choose the SD card to be Internal Storage or external/removable storage?
In case of Internal Storage, this choice tends to be troublesome and should be avoided. At least it seems to be a possible cause for the issue at hand …

1 Like

Thanks a lot, I configured it as internal storage. After choosing external storage, everything works fine again!
And sorry for my bad search skills.


1 Like