Wifi broken on FP4 after update to 1.5.1-s

Hi, I have a FP4 (bought in a Orange shop) on which I installed e/OS myself last January.
The upgrade to 1.5.1-s went fine and smooth… but I have serious trouble with the Wi-Fi now.
More precisely, I can connect to any network, but I can access the web only for a few minutes, after that I’m the dark.
I am then connected without having access.
To get it work again I have to reboot (disconnect/reconnect does not provide me internet access).

The biggest downside of it being that it drains my battery in a few hours if I don’t disable the Wi-Fi.

I tried on different networks (personal and professional) and the behavior is the same.
I did not change my network configuration, it was perfectly working before the update (and the same configuration is still working on my laptop).
I tried to modify the DNS parameters, the MAC randomness, and on different websites.

However, pinging an IP address on Termux is successful.
I guess there is an issue with the DNS setting then, that would explain why I can connect to networks without being able to access the web.

I created a log with logcat, but considering the huge variety of personal data in the file I would prefer to have a specific request.

I cannot create an account on the dedicated gitlab to open an issue because all my email addresses are not allowed for sign-up.

Is an upcoming update fixing this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Is a known issue, please follow the guidance here, Getting an error message in new ID creation on /e/OS Gitlab?

Re your broken WiFi issue, there seem to be some similar experiences being reported.

PS. Did you simply try

Settings > System > Reset options > Reset WiFi etc ?

I do not face those issues at all, and my wife neither. We are both on FP4 128GB/6GB /e/OS version 1.5.1-s stable.

Which exact version are you using? (device and software).

Resetting Wifi may or may not fix your issues, but will erase all your known WiFi passwords… (back-up them before doing so)

Reset my Wi-Fi worked: thanks a lot!
I note the guidelines for creating a gitlab account though :slight_smile:

Thanks @stanwood for the feedback as well.


Update: it only worked for a limited amount of time (similar to a reboot).
I tried to create an account on gitlab but no answer yet.

1 Like

I wonder … did you try to eliminate any side effect of Advanced Privacy by experimenting with switching off all or parts of it ?

1 Like

Thanks for the pointer, I didn’t think about it before!
Unfortunately, the settings were disabled (and trying various experiments with it didn’t work).

Problem solved here.
Basically, I had to switch off the Private DNS feature (in Network and Internet), and then disconnect and reconnect from the networks.
Thanks everyone!

I have the same issue, but unfortunately your fix only worked briefly for me - I had internet for maybe 20 minutes before I lost it again.

On FP4, android 12, /e/ OS version 1.5.1-s-20221102231514-stable-FP4, not rooted.
I briefly got internet after resetting wifi, but soon after lost internet.

I’ve reset my router, switch off MAC randomisation, switched off private DNS, switched off VPN, switched off Advanced Privacy, resetting in between all of these, and still no internet for longer than 5-20 minutes.

I updated to 28 Oct version beforehand, and then downloaded 2 Nov, so something happened between these two.

An update for anyone else having this issue; although I followed vmorel’s solution posted above, I still had to reset wifi settings to get internet several times. However last night my phone stayed connected all night without reset, with both VPNs and Advanced Privacy active. I will update if this changes.

UPDATE: An hour later and it has stopped working. Resetting WiFi is not working at the moment either.

It stopped working after a day, I reopened the issue here.