WiFi calling crash Motorola Ace 5G kiev

I am unable to enable WiFi Calling, the app crashes and WiFi calling remains OFF. Can anyone with the same phone can you check on your device.

I just started using this phone and failed to test it on 1.21T, currently it’s not working on 2.0T.

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphoneemphasized text

OK so I did a bit of research on the WiFi calling not working.

I searched the internet and found there may be some US carriers that don’t enable WiFi calling or it gets disabled with an unlock.

So I used the Lenovo tool to roll back my unlocked phone to it’s stock Canadian ROM. I then enabled WiFi calling using the stock Canadian ROM and made a few calls, it works fine with the stock ROM.

Because the last stock ROM was Android 11 I decided to go to eOS e-1.8.1-r. and test again. After the install I enabled WiFi and data and tried to enable WiFi calling. The WiFi calling button (slider) is indeed available but when you try to tuen it on it just turn back to off and WiFi calling is unavailable.

So my thought here is maybe the original ROM was built from one of the US (or other carrier) ROMs that disables WiFi calling with an unlock?

I don’t have the skill (yet) to compile an eOS ROM and depending on the difficulty I may never have that skill set LOL. I will post the file name of the stock Canadian ROM I used once I get home this evening. Perhaps someone with the skill could take a go at building from that ROM?

I know in the case of the OnePlus Nord if the 5G calling is not working in stock ROM it won’t in eOS either. I think Moto may be the same case. If anyone want to take a shot at this send me a message and I will make sure you get the ROM. Again I will post file name in a few hours from now.

TIA JETS

1 Like

The Canadian ROM name is:

KIEV_RETAIL_RZKS31.Q3_25_15_15_6_subsidy_DEFAULT_regulatory_XT2113_2_CANADA_cid50_CFC.xml

I don’t have the device to help, but I looked alot into IMS (VoLTE/WifiCall). You should look at adb logcat as you try to place wificalls, it will emit reasons why it won’t go forward. WifiCall uses carrier keys to setup the ipsec tunnel. Things could fail if you use another modem partition than your region (I guess).

tcecyk thanks for the input but it appears once the eOS ROM is loaded that WiFi calling is unavailable on the device.

What it does if I try to slid the slider ON it switches right back off and kicks me to back to the setting menu as if the function is unavailable.

I don’t fully understand what happens when a ROM is built but I think if the original stock ROM is built with the a given function OFF or not working it will inherit it in the eOS ROM.

Can I use logcat to trace what happens when I attempt to turn it on? I used logcat once before on the Nord so I am sure I can do it again.

I have a busy weekend but I will try to get to it in the next few days. I will post results soon.

You may be able to do easier than logcat if you search settings for “telemetry”. /e/OS telemetry is in System > Developer options.

While in Developer options, under “Bug report” is a setting to put a shortcut on Power menu.

OK I will give that a try this weekend. Thanks aibd

aidb,

I haven’t got around to doing this test, but set the above setting in my Pixel and understand usage.

The Moto is back at stock ROM and the WiFi calling works.

Once I have eOS reinstalled and submit the bug report with the power button(s) option, where does it go and how do I get bug feedback? Is a copy on the phone that I can upload to this thread?

This is a nice phone and would like to have it as an alternate to the Pixel.

As far as I understand the bug is not “directly” submitted at press of the shortcut from Power menu, rather bug report is saved to the device.

A notification is seen as the report is saved, at end of Save the notification shows a Share button. The .zip file can be emailed to say “own PC”. From there one can open / read the contents before deciding for yourself what to add to an existing or newly created Gitlab issue or even share on the forum.

Bug reports previously saved to device can be reached from a shortcut on the navigation pane of Files app.

Screenshots

Screenshot_20240711-062128_BlissLauncher


1 Like

So I finally got around to reinstalling eOS on this phone to do this test.

Once eOSr was installed it didn’t have the telemetry option but eOSs does. I tried to generate a bug by turning WiFi calling on but it just exhibits same behaviour slider just turns back off. I do get the error:
Setting Has Stopped
but only once and a while. No bug report is generated. I am going to update to eOSt now to see if anything changes.

So the above phone is now at eOS 2.2t and the Wifi calling still doesn’t work.

Trouble testing this phone is I have to remove SIM from my daily phone to test. No SIM installed can’t test WiFi calling.

I activate eOS telemetry and enabled the bug report button. Tried to enable WiFi and got the app to crash but no report was generated? Got the app to crash a few time too.

I guess I will have to use logcat, I will search it’s use. But as I say I can only test once and a while as I have to remove SIM from my daily phone.

Any tip on using logcat for this test?

I think from my observations that there are two modes.

  • Device should auto generate bug report in the event of a crash or certain failure.

  • User generated report by pressing the bug report button after some fail event. Hopefully this would generate quite a long report where one hopes to be able to identify the “fail event”.