Wifi calling not working anymore after latest FP4 update

Since the latest update, it seems that Wifi Calling is not working anymore on FP4.

It seems there was an Option added to the Settings to choose between Mobile Network or Wifi First.

Before the update there wasnt such a option (only On/Off switch for wifi calling) and it automatically switched to wifi calling when the mobile network was too bad.

Could we not get the old Setting back, it worked perfectly fine before :confused:

How do you check if it’s working?
Which provider are you using?
What’s the IMS status when checking by *#*#4636#*#* and selecting “phone information/Telefoninformation”?
For me (provider Vodafone on FP4) VoWiFi started to work with latest OS version…

well thats easy cause i dont have enough mobile network in my apartment to do calls, so if its not using wifi calling it will never start to dial.

also i tried to provoke it by turning airplane mode on and wifi on.

Also when it was working i was getting a little wifi symbol in the dial screen and then it also was a HD call, i still can see that call in my list:

Im honestly thinking about flashing the 1.0 version again now… Actually it might still have worked with the first 1.1 version but not anymore with the latest one.

for me it was 4636 instead of 4635:

Sorry, your number is correct. Was a typo.

I meant IMS status you get by using the three dots at top right menu of your screenshot:


Still it might be that 1.1 fixed it for my provider and broke it for MEDIONmobile. :thinking:
If you’re using a Murena FP4 you could open a ticket.
Or you wait until release of 1.2 which is currently in beta (which might fix it again).

hmm should be fine actually…

yep i bought it from murena, then ill probs open a Ticket.

1 Like


I have the same problem, but everything works fine, if I turn off the advanced privacy for the call.
With advanced privacy turned on the call won’t connect.
Maybe you could try that? :slight_smile:


oh, indeed, it seems to work with advanced privacy off. I only used Tracker Blocking though…

Thank you :slight_smile:

I Still should open an issue though, as both should work…

Yes, I would also be happier if that just worked! :grinning:
This was not meant to be a solution. It is just a work around and we now know what is causing the issue.
have a nice day! :grinning:

1 Like

Now that we now that Advanced Privacy caused the Wifi Calls not to work anymore i wanted to open an issue at gitlab, but when i tried to register it said, that my mail adress is not allowed.
@Manoj is there a reason for that?

You can refer this guide for suggestions

1 Like

In addition to your workaround, it seems to be fine Just not to block trackers for the phone app

even tough it doesnt have trackers according to advanced privacy

Kind of a weird behaviour, but thats a workaround i can live with :slight_smile: