Wifi calling only works with a VPN activated some times


I mainly use Wifi Calling. I force it setting “plane mode” and then turning on the wifi.
I noticed that sometimes, for any reason, when I try to give a call, there is first no tone, and then I am connected directly to the answering machine of my correspondent.
I notice that sometimes, in this case, I can give the call if I turn on the VPN.

Is there really a link? Or is it just because I tried a second time

If the VPN indeed enables the call, what does that mean? Is it a matter of network?

Thank you in advance for your insights!


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Can You provide more specific info on what kind of “VPN” are you using?
Advanced Privacy - hide my IP? some external service? some sort of tracker blocking or firewall-App?

VPN connections (especially external services) sometimes take a moment until fully ready - I imagine that when You are quick with dialing after switching VPN on: it might still connect correctly but the ringtone might simply get lost somehow (?)

Thank you very much @obacht for your answer!!

I should specify that the Wifi Calling works much better when VPN is On than when it is Off

It is Proton VPN

Here are the options that can be turned on or off :

  • VPN accelerator: On
  • DNS leak Protection: On
  • Netshield: On
  • Alternative Rotuing: On
  • Protocol: Smart (auto)
  • LAN connections: Off
  • Split Tunneling : Off
  • Moderate NAT : Off

Thanks again!!

I am sorry but my knowledge on wifi calling is pretty limited (rather non existing), I could only speculate on the VPN part… :grinning:
Does the issue depend on duration after VPN activation?

I am sure there’s someone more knowlegeable around.

PS have you checked with proton if that is maybe a known issue for wifi calls via their VPN?
edit: sorry I thoroughly misread your issue description even though it is wrapped up in the title :person_facepalming: - as the wifi call works bettter with VPN ON and has these issues w/o VPN it seems to rather be an issue with the general network connection (wifi) and/or its provider and not with VPN I would guess (?)

have you tried a second time w/o VPN already?

wificall is ipsec on udp to destination ports 500 + 4500 - so if @ThomaM is in a network that does anything to these flows he’ll have problems. When it is your home network, check the router config for port fitlering and network address translation (nat) settings - https://www.networkcomputing.com/networking/your-network-optimized-wifi-calling

Interesting when in the same network it sometimes works, sometimes doesn’t. Is the device connected to a wifi repeater then?

Enabling a vpn will free you of the packet filter rules the network imposes. Of course this can help with networks you can’t control


Thank you very much for these insights @tcecyk
Actually I am connected to the Wifi of my neighbors, so VPN will still help
Thanks again,

This topic was automatically closed after 90 days. New replies are no longer allowed.