Wifi connected but "no internet connection"

I’ve been using the great /e/os for a while.

Without changing anything, I suddenly can’t get an internet connection anymore.
I restarted the phone and tried four different routers.
An identical device with Android works.

Can someone help me?

Xiaomi Redmi Note 4
eMido-userdebug 9 PQ3A. 190801.002 eng.root.

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

1 Like

Sounds odd.

Where exactly do you get the statement “no internet connection” (system? app?)

Do you use any app that utilizes the VPN interface of the device? (switch off for testing)
Do you use Advanced Privacy? (switch off for testing)
What about internet connection via mobile data?

1 Like

If the device gets an DHCP IP lease but can’t connect to the internet, it may have wrong DNS settings. Check if there is anything configured under “Private DNS” on the device and try automatic, off or quad9 and see if it changes anything.

1 Like

Thanks for the fast respond.

The message comes from the system (x in the wifi symbol).
No VPN APP. Only Blokada-App. Uninstalled, without success.
I don’t use Advanced Privacy. The settings under “Securitly&Privacy” all seem unchanged.
connection via mobile data works.
I can also access the local WiFi network.
Other than updates, I didn’t change anything on the device at the time of the error.

However, I had an Amazon Fire stick that I wanted to root connected to the WiFi. Maybe e/OS/ is offended :wink:
(I sent a few commands to the stick via ADB. But that can’t be it?)

“Private DNS” was set to automatic. I tried all the settings. Unfortunately without success.

I just noticed that the wifi is working. So it just displays incorrectly.

good it works! … is the behaviour reproducable?

I had this somewhat similar issue with Version 1.21 Feedback for v1.21 - #248 by obacht

1 Like

No, since the error occurred it has been there constantly. I don’t have any restrictions in using.
It’s just blemish and doesn’t affect the function.

1 Like

You might report an issue here if you want to: https://doc.e.foundation/support-topics/report-an-issue.html

I think it would be good to have that thread in the device-specific section because more xiaomi owners would see it then and maybe they have an idea about it… not sure though if you can change the flags…
@Manoj can you please move that thread over to “eOS devices” - “Xiaomi”?

edit: maybe not device-specific?

1 Like

I have the same issue on Xiami MI8 (/e/OS 0.23-20220412177701).
“No internet connexion” is displayed when I’m in wifi (below the wifi symbol) and when I’m in mobile data.
I have access to internet since I can access internet pages with Firefox.
But some applications seem to use this status. I’m no more able to update my podcast with AntennaPod and messages are no more sent with Conversation.

I tried to report an issue but can’t register at gitlab-server, Tried several E-Mail addresses:

1 error prohibited this benutzer from being saved:

E-Mail ist für die Anmeldung nicht erlaubt. Bitte verwende deine reguläre E-Mail-Adresse. Wende dich an deinen Administrator.

To those with the issue: What’s your mobile internet provider?
Mine is O2, Germany, issue occured on FP3 somewhat tonight.

I think it has nothing to do with the mobile internet (here: D1, Germany). I also tested different DSL providers without success.

On my side, I’m using Free in France.

look here, same page, should be solved easily via mail to helpdesk as explained, it´s a common issue:

Getting an error message in new ID creation on /e/OS Gitlab?

  • Some users may get an error message, while attempting to create a new ID on the /e/OS Gitlab
  • The error message may ask you to contact Murena at helpdesk@murena.com.
  • In case you run into such an error, please send a mail with the following details
    • Full Name:
    • Desired username:
    • Email:
  • Create a Helpdesk ticket for GitLab account creation
  • Let us explain the reason behind this error. Some time back we had an issue with a large number of dummy IDs swamping our servers. As a preventive measure we now allow registrations from a limited number of email domains. Users wanting to register with their private email address or say their Gmail address, can send a request to helpdesk@murena.com and the team will create an account for them.

I suggest we continue the discussion here: Wifi shows as no internet - #12 by Ytux

1 Like