Wifi connected but no internet

I am trying to get a softphone to work but I don’t have internet access on wifi. When I go into settings and look at the wifi setting it says no internet. My browser does not work either. I have mobile data turned off because I am trying to get wifi to work. I can see my phone from the router. I updated /e/os yesterday to 1.6 221208. I am using a Oneplus 8. Wifi worked while on android 11 but never has on e.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

do you use MAC whitelisting at the router level? in a recent thread this was at issue with the Android doing MAC randomization every other boot

1 Like

I was using Mac filtering on a old router but I replaced the router with a Tplink archer c8 and I can’t find any Mac filtering setting like the old one had. I did find an arp table that my phone was not in so added all and my phone was added. I don’t know what difference that makes. I was in a different location today and I tried a different router that I was assured was not using Mac filtering and the phone said it was connected and didn’t say anything about not being connected but the browser could not find anything like bing.com. I tried disabling random mac addresses but it didn’t make any difference. I also tried changing the DNS from network supplied to one from Nordvpn but it didn’t make any difference. Where do I find the log? Thank you.

if you’re not actively use mac filtering than you can ignore this. Disable any VPN (or Advanced Privacys “hide ip” feature) and if the network-DNS isn’t helping, might give a public resolver a try - 1.1.1.1 or 8.8.8.8

There is an app called “Ping & Net” (com.ulfdittmer.android.ping) which can help with diagnostic.
For example, sharing here the display off “Network Info” (hiding External IP if displayed).

I tried turning off VPN but still no Internet. I reinstalled /e/ and still no Internet. I tried a different location with a different router and then I was able to get Internet. Makes me think it’s my router but I am not using Mac filtering or a VPN and everything else work including other android phones and Linux laptops. I will check out Ping & Net but I can ping my phone from the router. I looked at the log on the router and I didn’t see anything odd.

Even if there’s no MAC filtering on router, MAC address randomization on device can break internet access with some routers.
Happened to me, I didn’t took the time to dig into, but seems related to ARP cache tables on router.

  • Check if the other apps have internet over Wi-Fi.
  • If possible, check if the Browser connects from the mobile network and not from Wi-Fi
  • Finally, if it is a DNS problem, you should be able to connect from the Browser, directly entering the IP (i.e. https://1.1.1.1/)