"WIFI Direct" is not working


I have installed e/OS 1.10 on a Samsung Galaxy S9 and now I’m trying to transfer my Signal account from my old phone.

Signal needs WIFI Direct to transfer accounts between two phones. The transfer fails, so I checked the WIFI Direct Settings. On the S9, it does not find the old phone. The old phone finds the S9, but not the other way around. The list of devices is empty and a click on the “Searching…” menu item doesn’t change anything.

I read that WIFI Direct requires Location (GPS) to work. I activated Location, but I’m not able to find a setting for using GPS, so I assume that this in enabled by default and cannot be changed.

Is there anything I can try to find the cause of this problem?

Thank you!

If the process depends on location, I guess you will need Advanced Privacy fully off.

A forum search of wifi direct shows many results – I did not check to see how many are success.

Thank you!

Unfortunately, turning Advanced Privacy completely off didn’t help. Before that, only Trackers where denied, Location and IP Address were exposed.

There are some related questions already, but none answered.

Hello @MrSparkle3 and welcome aboard… :slight_smile:

Based upon the Signal support page please be assure to check the “still having trouble” part of the support site for WiFi-Direct-Transfer method described here: → https://support.signal.org/hc/en-us/articles/360007059752-Backup-and-Restore-Messages#android_restore_steps

(Alternatively you can also try backup and restore (file transfer method) described on the same support site. So you can at least get your Signal account working on your new device.)

Do you have access to other WiFi-Direct devices (like a Smart TV f.e.) to check, if your S9 maybe finds them? It could possibly be that your old device is hiding for whatabout reason (and therefore maybe the cause of this issue).

Thank you!

Yes, I tried all of that. I allowed all required permissions, I don’t have any active WIFI hotspots and I deactivated Advanced Privacy. My old (Android Phone) finds my new phone, the phone of my wife (also S9 with e/OS), and the Smart TV of our neighbor. My new phone (as well as that of my wife) doesn’t find any of those devices.

From reading through the other related topics in this forum, I got the impression that this problem exists for some time now, and that it might not be related to the model of the phone. Maybe e/OS has some additional privacy protection that prevents it from seeing other devices (but not preventing being seen from other devices) through WIFI Direct?

Can anyone confirm that WIFI Direct works on their phones with e/OS?

PS: I also updated my phone to e/OS 1.11, but it didn’t change the behavior of WIFI Direct.

Ok that’s weird. If the related forum topics and no other user with starlte can’t help any further, you may open an issue ticket on Gitlab. → https://gitlab.e.foundation/groups/e/-/issues I did a quick search for starlte and/or WiFi-Direct issues, but there seems to be no entry.

I don’t use this feature often, but actually on /e/ OS 1.11 (Xiaomi Mi 10T Pro/ apollon) i am able to connect to my Smart-TV successfully as shown below. This worked on the same device with an older /e/ version too (can’t remember which version it was).

“Verfügbare Geräte” means “available devices”.
“Verbunden” means “connected”.

Hello,i can confirm that wifi direct works fine on my Gigaset GS290 with /e/ os.
While my samsung Galaxy s9 has the same issue .Its visible to other devices via wifi direct ,but the dialog does not show any other device .

Thanks everybody.

I tried to create an issue on GitLab, but I can’t even register. It says: “1 error prohibited this user from being saved: Email is not allowed for sign-up. Please use your regular email address. Check with your administrator.”

I couldn’t find any contact data where to ask what’s going on there.

So I give up now, finally.

You can check out the information in this guide