Wifi hot spot not working Herolte S7

I have an S7 SM-G930F that I flashed with the easy installer and I’m encountering the following problem:

  • If I share the wifi as a hot spot for more than one device it shuts down after a while. It does not respond after that and I have to restart the phone.
  • If I use it only to share internet for one device sometimes it’s OK, sometime is does not work… I encounter the same problem.
    It’s kind of blocking as I use my phone for my Internet connection at home.
    May I provide some logs or anything else to help you troubleshoot this issue?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


if the issue isn’t hardware (so if it was perfectly working before), you could open a “New issue” in the gitlab.

You can generate logs using this method or this one, and then share the file in the issue with the “Attach a file” button.

But don’t expect a quick action.

You could also install the last dev Oreo (Android 8) build instead of the stable Nougat (Android 7) build you installed thanks to the Easy Installer. Maybe the issue will be fixed.

To install Oreo (expect to loose your data):

  • download the latest zip file here (directly via the Browser, or via your laptop and then by transferring the file into the internal storage of the phone),
  • go into the recovery mode (TWRP) : turn off the device and then long press for multiple seconds on the Power + Home + Volume plus
  • Slide the arrow to allow modifications (if prompted to do so)
  • You should be in the main menu, click on Install, click on the zip file you previously downloaded and swipe to confirm the flash.

You could try to “Reboot System” (and click on “Do Not Install” if prompted), it will probably work and you won’t even have to restore your data.

Though you could also come back to the main menu of TWRP and do a Wipe > Format Data > yes to delete data in order to start from a clean installation.

Thanks for the response. I think I will go with the Oreo flash in order to check if there’s a solution for the problem coming with the update. If you are working on this release by now then I prefer to test it and report new bugs or problems. It will be more useful for everybody.
Thanks for the explanation!
I will let you know if this solves the problem responding to this thread. Will try to flash it soon.
Have a nice day.

Hi! I’ve made the install and everything worked smoothly but the SMSC configuration. I don’t know how to configure it. I can’ receive any messages. I’m using Free Mobile from France. If anyone who has the same problem can give me some help I would appreciate it. I’m posting this in the french forum as well.
Thanks anyways for the procedure. It worked :slight_smile:

Hello @luchoArg34, I suggest you to try to change the APN settings, available here.

Dear All,

Once upgrading my S7 to Oreo (ROM 0.13-20200120889191), the wifi hotspot became randomly unstable. It was pretty stable with previous ROM. I notice sharing connection with USB modem is pretty stable, so I can not be the 4G or so. Any idea of a solution ?



Hi tonton. I have the same problem but with version 0.12 (oreo). My phone is an S7 SM-G930F. The workaround was to share Internet via Usb cable. I did not find any other solution. Hope you did :slight_smile:

Hi @tonton1 I had the same problems with the hotspot. I decided to upgrade e OS to Q version 0.15 (unofficial). Problems are solved =) If you are doing it install “simple dialer” right after flashing the phone. The default dialing application won’t work, it crashes. You can find Q here:


Hi @luchoArg34, thanks for the tip. I will wait the official 0.15 version in Android Q…I guess the phone dialer issue will be fixed by then. Mainwhile the wifi hotspot issue remain (I am 0.15 on android 8.1)…wait and see.