Wifi not working

Hi Nickyr,
here you can find the two last boot images of GS290 (Stock ROM) with timestamp YYYYMMDD. Be careful and use the commands in the order I sent before in the same post! Good luck! Best Regards - Didi

Hej Didi_6763,
this did the trick - thank you so much to you and the forum in general!
Best Regards,

Hi Didi
I’m confused. Why would efoundation send out an update with an older boot.img than the previous version. And if this is correct we should be telling them not to do this I think!

Hi AndyP,
why this is so - we can only make speculations. E.g. too many Devices to maintain and so on. Or for a long time Gigaset did not bring out updates for the GS290 device. And now e.foundation is still not aware that there are Updates from November and December 2021. But you are right somebody has to inform the developers/support that some functions are not working with the deliverd boot.img from e.foundation - and with the newer versions of Stock ROM it does. I needed the devices running, because I bought them as christmas presents - so I struggled to find a fast solution. So please open a ticket at the support if you have still problems with your WiFi. This is the best way that in future all owners of gs290 have can enjoy benefit of the global solved problem! Software Development is an always lasting improvement process!
Best Regards

1 Like

OK Didi will do…I’ve logged it at the wiki already.
Wish I could go back to 0.18 as it was perfect for me.

Hi @AndyP thank you for reporting this … but as this thread is marked Solved, it may not be the best place to raise awareness.

I see here /e/ image ROM download that a v0.18 is still available; you wish you could go back? - a downgrade of /e/ version is fairly painless.

I see also your post 0.20 is a disaster for GS290 - #3 by AndyP.

You mention a wiki post you already made - please can you provide a link - this issue does require some visibility! :slight_smile:

In a quick search I find no mention in a Gitlab search for GS290 issues.

First thing, then, Report an issue.

If first time users have any issues logging in to Gitlab, it is a known issue. In the event you cannot login, please provide details of your failing ID to support@e.email asking for assistance.

PS Correction @AndyP, sorry, I found this: problems reconnecting wifi (#4093) · Issues · e / Backlog · GitLab - but the issue is not tagged GS290!

1 Like

aibd- thank you! …I had no idea I could wind back to 0.18.

The last few weeks have been painful :slight_smile:

I will tag my post now, I had no idea I had to tag it.

How do I wind back to 0.18…and will I loose all my data?

No, you will not have to wipe Data with a change of /e/ version - that is only required with an Android upgrade.I will write as if you have TWRP if you have an /e/ Recovery, the steps might be a little bit different!

Transfer the .zip to your SD card (or it can be the phone’s internal storage).

Reboot into Recovery mode,

TWRP will be able to find the .zip by:

Install > up a level > Select: external_sd > scroll to files > Select your copied image …

Note, uncheck, signature verification, I tend to leave unchecked automatic reboot.

Swipe to confirm flash.

Once the flash is reported successful, go back > back,

Advanced wipe of Cache and Dalvic / Art Cache

Then > back, Reboot > System

If this action proves successful it might support the idea that this is a ~v0.19 Regression as proposed by that particular topic - and not the wider issue of a mismatch between Gigaset firmware and underlying stock used by /e/, as suggested by @Didi_6763 in Post #11

1 Like

It’s true that you should not lose data, but I think it is a good idea to take a TWRP backup of your data partition before you install the 0.18 ROM, juts in case. The ‘backdate’ use case has not had as much use as the 'update`, so it is possible that you may encounter problems. Better safe than sorry :slight_smile:


Thank you aibd…will get to this later today and will report back.

For the GS290 what image should I use- there is only a Gigaset GS4? Also my device is not rooted, can I still do this?

I do not understand, please can you ask the question in different words! :slight_smile:

… also /e/ does not expect or require rooting.

This was the link I posted earlier /e/ image ROM download

I got past the asking for root access page and I think I have installedTWRP.

On opening… it trys to access Google… but ‘microG Services Core’ brings up a warning and stops it?

Then I hit cancel to get to TWRP landing screen.
Then I hit TWRP FLASH (top option) and it crashes.
OK re-started my phone and now it does not crash.

When I try to reboot into recovery mode it says ‘Root Access Required’

It sounds as if you were trying to install Official TWRP App - this actually does a quite different job from Recovery.

You can simply boot into Recovery mode, to see if you have TWRP. If you find that you have /e/ Recovery, perhaps see if the process still looks intuitive with the information you have.

The process is covered in this tutorial (the link aims to drop you in at (8) Install /e/ without computer from your device, with TWRP using the SDcard method > sub section B) Transfer the /e/ ROM to the internal storage of the smartphone

As usual, please backup all your data first. Any problems please ask again.

Yes I was trying to use the Official TWRP App…
I’ll try you advice today.
Thanks you!

You might also review whether your issue is related to the newly reported GS290: after installing /e/OS, BT and WiFi do not work.

Cross reference Post #77 Documentation Suggestions GS290


I had the same problem with Wifi not reconnecting and followed hints above: Wifi not working - #6 by Didi_6763

But now after reboot the WIFi is not possible to even enable.
what can I do to fix this?


Hi Handango,

you could try to download and flash one of the stock boot.img files from my link a few enties above.

Best Regards…


I used the stock ones from your link: https://ecloud.global/s/qWdNsBQEFRJrgJd and followed your steps in Wifi not working - #6 by Didi_6763

I tried both boot.img in the folder of the link. both did not work .
I have a Gs290 directly bought from EFoundation - could I perhaps revert to the default EOs boot.img?

Hi Didi, I’ve just install /e/ with the easy installer and have no wifi or bluetooth, could you help me? or point me to an easy solution? Thank you