Windows 11 USB driver for bootloader

Hi All,
on Mac, using parallel to have windows 11 (cannot have lower windoms as Mac M1 chip)
Windows 11 recognises the phone but not the bootloader… seem to me that I tried ALL the drivers available online and every ways to install it…
still the bootloader is not recognised with the exclamation points on the phone in the device manager.

anyone has an idea ?

Thanks in advance for your replies

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I cannot comment on the Mac angle, but did you run Windows update while the device is connected by USB cable in bootloader mode – also in Recovery mode ? – or does the Mac preclude this option?

What model is the phone ?

1 Like

thanks aibd,
phone in Fairphone 4
windows update does not show anything, even in optional update,
tried the recovery mode and update the driver while in recovery … no change

Does it look like this in device manager?

If so, then try this:
Right click → Update driver → Browse my computer for drivers → Let me pick from a list of available drivers on my computer → Android Device → Android Bootloader Interface → next → yes

1 Like

Will this help?

This is really important. Windows needs an extra driver for fastboot (aka bootloader) mode, so the phone really has to be connected while being in fastboot mode.

Windows 11 itself shouldn’t be the problem, I’m using it myself and ADB as well as fastboot are working just fine.
And if the phone is recognised in general on the Windows side, USB passthrough in the virtual machine seems not to be the problem either, or are there settings or permissions or anything for USB in Parallels?

The internet says …

Thanks NoNeed, yes it looks like this, though
“android Device” does not appear in the list when plugged in fastboot mode,

the device appear as “Android” in the list of USB plugged to Parallel 18

Thanks smu44… tried that too…
Thanks AnotherElk i’ll try downgrading Parallel

Just to clarify, the full test would be to

  • plug in device
  • switch to fastboot mode
  • fastboot devices

Now I expect Windows Device manager to show a :warning: of some sort.

Can you confirm that does not happen ?

You can also use View any installed/connected USB device on your system and Alternative to device manager of Windows for an enhanced view.


following this, “Android Device” does not appear in the list,

thanks smu44… i used them both… can see the “Android” in both but the device manager still does not recognise this “android” and shows the exclamation

You may choose “Have disk” then browse to the folder where you extracted the Google drivers (see my post #6).