WLAN-hotspot Sony Xperia Z5 compact

Hi everybody,

since i have not found anything related, i opened a new thread.

On my Z5c /e is running fine with Nova-Launcher. Today i tried to activate the WiFi-hotspot… it`s switching back to off after 1 second. I tried switching on/of WLAN, same procedure. I tried with/without WPA2, 2,4GHz/5GHz… still off after 1 second. In the overview “Homespot and Tethering” under WLAN-Hotspot “error” is shown.

After the last update /e/OS 0.21-20220125158734 (Android 11) is running.

Do you have any ideas?



Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Thanks for the report.

I can confirm this behaviour is happening in R build, but not in Q build. I will check whether it is happening in the upstream LineageOS 18.1 ROM or whether it is a problem just with /e/OS. I will raise the necessary gitlab issue report.

I have created a gitlab issue, and will try to ensure it is fixed ASAP

I’ve tried the earlier R builds, and hotspot has never worked in R on this device :frowning: I will try to make sure that testing hotspot functionality is included on the test plans for new releases. (It’s not in the test plans used for releases up to now.

Until this problem is fixed, I suggest reverting to the latest Android Q build from here

Hi petefoth,

thanks for your answer, i will check out the Q. When R is out oft beta status, next try…

Greets and thanks again!


1 Like

The problem has been fixed, and the fix should be included in the upcoming v0.22-r release. Details: