Won't play 1440p videos, crashes on e-1.20-T

NewPipe, Gallery and VLC crash trying to play 1440p youtube video.
It used to work on e-1.19.1-S
Any 1440p video will crash. It may just 1440, 1440p60 - all crash
1080, 1080p60, 2160, 2160p60 works no problem

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

I’ve upgraded my galaxy s10+ with 1.20 T, and have problem to play any videos with each gallery or players from os.
But it works fine with xplayer
Which device do you have the problem ?
s10 too possibly?

Weirdly enough I haven’t mention device.

Samsung Galaxy S10+ SM-G975F/DS beyond2lte

Doesn’t matter if it is clean fresh flash with prior Samsung ROM or upgrade from e-1.19.1-S. Result is same. Yes, I have 2 such mobiles.

I’ve seen your post on an other topic for the s10+ upgrade.
Then afterwards this new one with the same person, then I was curious if it impacts me, i’ve tested on mine too…
“Le hasard parfois fait bien les choses” :wink:

Did you tried with the xplayer app?

maybe there is a problem with a codec…
is there some options vlc on android to choose a specific codec or install an other one ?

I aim at keeping most of my apps fully FOSS.
All my daily driver apps are FOSS, except banking and eBay.
I don’t see xplayer in f-droid.l

Maybe that is Debian Linux spilling into my phone philosophy. I used Nokia N900 and, if something of that format would pop up in future I would definitely get one.

I would try some other video player in near future.

That’s a great goal from you I think, and not really easy.

You’ve still the N990 on working ? and with original OS?

If you find a good player could you please give it the info here? or in an appropriate topic?
I’ll try to do it on my side too…

@wizard curiously after having post the last message, I’ve remarked that all video which where fixed are now well functionning.
I don’t don’t know what’s happened there on my side. In between I’ve rerestart the phone, and not really understand why it works now by me.
Could you check it again on your side, maybe after having restarted your phone?

I fear restart.
Every time I restart something breaks.
Before eOS-1.20-T it was GPS.
Now settings simply disappear.

As much as I can I don’t want to do any reboots.
If not for GPS troubles, I would be on 6th boot now - 5 updates, one dead battery. Because of GPS it is 126th boot. That is combined boot count for 2 desktops, laptop, 3 tablets, backup NAS Nextcloud server, 2 real server and 3 Raspberry Pi 4B in last 5 years. That includes 2 Debian version upgrades on all those devices.

I still have problem with 1440p videos.

On subject of Nokia N900. I stopped using N900 back in 2015 and sold all 3 my devices. Since I have got 2 other, but maemo repo is dead. I guess other repos I have been using are dead too. I used community updates. It was quite good. Have had massive amount of customisations. I don’t think I used 3rd party video player.

strange… I’ve no problem with gps and seeing 1440p videos…
what kind of video it is? some of them are from stream data like youtube of something else?
If one could be streamed you could give me the link and I’d try to read it…

It have not crashed on NewPipe, but I got black screen

Funny enough now both VLC and Gallery will play 1440p after download

by me the video of your link works well in firefox and vlc. adhoc with no strange behavior before or interferences…

I just stumbled upon something absolutely unexpected. I was playing 1440p60 video on VLC https://www.youtube.com/watch?v=FCIeqRgRNSQ
I was able to play 1440p and 1440p60 videos on some occasions. I may just discovered, when it reliably works. It was just before 6am, when I was playing 1440p60 video. It was after dusk, but before sunrise. And then I see blue light filter turning off. Right after blue light got full intensity (blue light filter turned off completely) screen went completely black - blank. It can be recovered by turning blue light filter back on.

That is quite unexpected 1440p video playback being dependent on blue light filter.