XA2 Ultra Discovery failure - help pls?

I’m very much a novice at all this. But I’m good at following instructions. XA2 Ultra is definitely much, much more difficult to flash /e/ onto than Redmi4X, my “test phone”, which I’m having to use now.

Many things didn’t happen the way the instructions said they would, and I tried various ways to keep going like I had on the Redmi - but let me tell you all where I’m stuck. Maybe you can help?

When I’m in TWRP (old version, like the troubleshooting says), I have no ADB permission, so can’t sideload 1.15. When I’m in the /e/ img, and try to sideload through Terminal commands, both normal and pre-kitkat fail. The phone no longer boots normally - maybe no OS anymore. Partitions are already wiped - I’d like to try the final /e/ sideloading, if I can, before I give up on the phone. Is there any way for me to do this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

What do you mean by this?
Also what os/pc are you using?

Sorry, trying to keep it simple. Win10 computer, not mine, so limited on what I can do on it.
This img: " 4. Temporarily flash a recovery on your device by typing: fastboot flash recovery <recovery_filename>.img"

That command won’t work. There is not a distinct recovery partition on the xa2.

In fastboot mode you have a choice:

fastboot boot <whateverrecovery.img>

This should boot the recovery .img from pc directly onto phone.

or, if that doesn’t do it,

fastboot flash boot <whatever.img>

This flashes the recovery image to the boot partition where it resides. Nothing will happen on device screen. Power off the phone (unplug=easiest) and manual boot recovery by holding vol down and power until 1 vibration, then release. Recovery should boot.

Then plug back in and continue…

Yes, I did the 3rd option because I read about the “critical flaw” in the comments. That’s also how I was able to get a working TWRP in my phone, with fastboot flash boot. I worked on it for around 6 or 7 hours today, always reading before doing. Here is how my experience differed from the instructions, to the best of my recollection:

  1. Unlocking. Instructions said there would be a popup on the XA2 Ultra to enter the unlock code. There wasn’t. I repeated steps, researched, etc, only to find out an hour later that the unlock code needed to be sent by adb in Terminal from PC. Finally successfully did that.

  2. I used the method you suggested the very first time to fastboot flash boot the .img. Going into recovery mode, the black screen threw me off, since I was expecting something like the Redmi4X graphical interface, and I flailed around a bit more.

  3. I managed to do a factory reset through the /e/ recovery file. I checked to make sure Android 9 was up to date as instructed, and checked the usb debugging settings that the instructions said needed to be re-enabled. They were already fine, but I started getting warnings when rebooting about unlocked not being able to be checked for corruption, and needing to relock.

  4. I did the “mandatory” copy pre-install slot a slot b thing somewhere around here too. I think through adb in Terminal, since I still hadn’t gotten TWRP recovery mode to work yet. I thought, if fastboot is black screen on Sony, maybe its all black screen.

  5. I finally remembered the troubleshooting notes at the bottom, since I had yet to successfully enter recovery mode. They suggested I download and use an earlier version of TWRP, so I went to their website and got one, then somehow got it onto the phone and working. Cache was not available to wipe, so wiped system and a two word cache option. Probably yet another mistake. After this point I was no longer able to boot normally.

  6. Getting warning messages about not having an OS. Unable to boot into normal usage. No ADB permission under TWRP, no way to sideload in /e/ recovery. So you know what? I’m probably screwed. But without /e/, my phone is at the end of it’s lifetime anyway. At least I can set up a new, refurbished phone with privacy and security if I can just learn how to do it.

  7. One step left. It’s probably too late, but wanted to try to somehow sideload /e/ on the phone. Even if it doesn’t work, maybe I can learn from HOW it doesn’t work. Maybe I can learn enough to finally degoogle my whole family, before we all have to buy replacements for our dying devices and have to wait another few years before we can try again.

So, that’s the full story. How can I sideload /e/ on my ruined XA2 Ultra in spite of the dumb mistakes I’ve made in the process of learning?

I’ve been using /e/ for months now on an old redmi4x test phone. Two installs after briefly trying Ubuntu. I thought I was ready to /e/ify the whole family.

First of all , don’t worry; these phones can take it! As long as you can boot a recovery you should be ok.

You’ve unlocked the bootloader so that’s done, you don’t have to worry about that again. Ignore splash screen warnings about unlocked bootloader.

Sounds like you are trying to use twrp recovery and the e-recovery as well?? Not sure what you are doing.

You can sideload from e-recovery. Can you manually boot it up into recovery while unplugged from pc? (by holding vol down and power until 1 vibration, then release. Recovery should boot.)

Or just fastboot flash boot recovery again if you haven’t got it manually (fastboot mode on phone, obv.)

I tried using each, multiple times. So I should forget about TWRP? I would be happy to sideload from e-recovery, but I can’t figure out how, specifically.

Yes, stick to e-recovery for now, I’ll talk you through it. Can you boot e-recovery on the phone?

When you have e-recovery booted, follow the Lineage instructions for sideloading the e-OS-dev.zip: go to the “Installing Lineage OS from recovery” section, and follow it step by step (except you will use eOS :wink:) Don’t miss the factory reset/format data.

1 Like

yes, several times. (alternating with TWRP when I was trying to get them to work together). Assume I’m back on e-recovery. Now what?

See the post above…

Here is an edited extract from another post. Describing the steps in e-recovery.

On Phone navigate to ‘Factory Reset’ and press to confirm.

This will take you to another screen to confirm you want to ‘Factory reset and Format Data’ etc. Do that also and the device is now wiped.

Navigate to ‘Apply update’ and select. Select also ‘Apply from ADB’.

The recovery screen should now show a small message at the bottom: ‘Now send the package you want to apply…’ etc.

On the computer type the command:

adb sideload <e-0.15-q-2021...whatever.zip>

Terminal output should show that the zip is being served to the phone. Normally it goes to ~47% and then it may feel like nothing is happening, but just wait.

There will be some output on the bottom of the phone recovery screen: ‘step1’ followed by ‘step 2’. Again it might feel like nothing is happening, but just wait… When the zip file is completely loaded the recovery screen changes and you will see that you have an option to ‘Reboot system now’

At this point you can unplug phone and select ‘Reboot system now’

It’s working! Why this time and not all the other times I tried?

(Also, will plain vanilla XA2 be similar? My wife’s phone is next)

You weren’t doing it right

I would suggest you carefully follow all the steps, one at a time, in the Lineage instructions.

Use the e-recovery bundled with the OS.zip.

I would further suggest, especially as it is someone else’s phone :wink:, that you install e OS version 0.14-q using it’s matching recovery. This way, once the phone has booted into the operating system and set-up , you can take an OTA update which will present itself in the system updater and update it to the latest version: 0.15-q without computer hassle.

This has the benefit (if it works ok, obv) of knowing both slots are in order. The XA2 is and A/B slot device.

lol! You are totally my hero. I was ready to give up. Thank you, from the bottom of my heart.

1 Like

Hey @hkmike, you are welcome! And I’m glad you got it going in the end. I had the same problems about a year ago :joy:

@chrisrg Do you recommend the dd solution here

to fix the dialler/sms/simcard issue?

I don’t know anything about that, sorry.