Xiaomi Mi 10 5G (UMI)

Looking for a possible version of Xiaomi MI 10 5G, codename: Umi, that was released on February 14, 2020.

Device specifications

Basic Spec Sheet
CPU Octa-core (1x2.84 GHz Cortex-A77 & 3x2.42 GHz Cortex-A77 & 4x1.80 GHz Cortex-A55)
Chipset Qualcomm SM8250 Snapdragon 865 5G (7 nm+)
GPU Adreno 650
Memory 6/8/12 GB
Shipped Android Version 10
Latest Android Version 13
Storage 128/256 GB
MicroSD N/A
Battery 4780 mAh (non-removable)
Dimensions 162.5 x 74.8 x 9 mm (6.40 x 2.94 x 0.35 in)
Display 1080 x 2340 pixels, 19.5:9 ratio (~386 ppi density)
Rear Camera 4
Camera 1 108 MP, f/1.7, (wide), 1/1.33", 0.8µm, PDAF, OIS
Camera 2 13 MP, f/2.4, 12mm (ultrawide), 1/3.06", 1.12µm
Camera 3 2 MP, f/2.4, (macro)
Camera 4 2 MP, f/2.4, (depth)
Front Camera 20 MP, f/2.0, (wide), 1/3", 0.9µm
Release Date February 2020


Xiaomi Mi 10 | XDA Forums

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Nice request formatting, dude ! :sunglasses:

Then I rise-up with lineage-umi-microg: it would be great to establish some kind of collaboration with them !

1 Like

I tried to build but got errors I could not address. Maybe someone wants to pick this up?

1 Like

There is also https://github.com/chaptsand/android_device_xiaomi_umi, did you try this @ronnz98 ?

1 Like

yes I saw it but there seems only to include a prebuild kernel for Umi which I don’t know to build. Do you have experience with prebuild kernels?

1 Like

No, I don’t … only a very quick look … but I did notice that the Lineage-19.1 kernel version is not default. Am I wrong to assume that “prebuilt kernel files” are “ready to go” – I guess that is what you are finding ?

1 Like

I tried now both sources for LOS20 with 3 kernels in total and could not successfully build…sorry

1 Like

So, is there no possibility of getting /e for this phone?

Yes there is! I will try when sources are updated…
Or maybe someone with more build experience than me make a try

sounds good.

fingers crossed

Thank you for your efforts!

I tried now again to build but got this error:

[ 76% 123656/162513] Copy init script: out/target/product/umi/system/etc/init/heapprofd.rc
FAILED: out/target/product/umi/system/etc/init/heapprofd.rc
/bin/bash -c “(out/host/linux-x86/bin/host_init_verifier -p out/target/product/umi/obj/ETC/passwd_system_intermediates/passwd_system -p out/target/product/umi/obj/ETC/passwd_system_ext_intermediates/passwd_system_ext -p out/target/product/umi/obj/ETC/passwd_vendor_intermediates/passwd_vendor -p out/target/product/umi/obj/ETC/passwd_odm_intermediates/passwd_odm -p out/target/produ
ct/umi/obj/ETC/passwd_product_intermediates/passwd_product --property-contexts=out/target/product/umi/obj/ETC/plat_property_contexts_intermediates/plat_property_contexts --property-contexts=out/target/product/umi/obj/ETC/system_ext_property_contexts_intermediates/system_ext_property_contexts --property-contexts=out/target/product/umi/obj/ETC/product_property_contexts_intermediate
s/product_property_contexts --property-contexts=out/target/product/umi/obj/ETC/vendor_property_contexts_intermediates/vendor_property_contexts --property-contexts=out/target/product/umi/obj/ETC/odm_property_contexts_intermediates/odm_property_contexts external/perfetto/heapprofd.rc ) && (mkdir -p out/target/product/umi/system/etc/init/ ) && (rm -f out/target/product/umi/system/et
c/init/heapprofd.rc ) && (cp "external/perfetto/heapprofd.rc" "out/target/product/umi/system/etc/init/heapprofd.rc" )”
host_init_verifier: Could not read line from ‘out/target/product/umi/obj/ETC/vendor_property_contexts_intermediates/vendor_property_contexts’: Match operation ‘u:object_r:vendor_fingerprint_prop:s0’ is not valid: must be either ‘prefix’ or ‘exact’
17:12:55 ninja failed with: exit status 1

Any ideas how this can be addressed?

I was considering if the subject here seems to be about

# ro.build.fingerprint is either set in /system/build.prop, or is
# set at runtime by system_server.
ro.build.fingerprint u:object_r:fingerprint_prop:s0 exact string

Could not read line from

You could go back up files in the trace to investigate what is missing / corrupted.

Fingerprints demystified

Maybe useful – for a different subject I had this bookmarked https://stackoverflow.com/questions/28776970/android-build-error-ro-build-fingerprint-cannot-exceed-91-bytes.

You might consider an updated variation of this suggestion

You could experiment with specify the build fingerprint string as command line argument to make using:
make -j5 BUILD_FINGERPRINT=".....".

I did a stupid mistake on my first try, but now could successfully build for /e/OS-S