Xiaomi mi 6x not taking /e/os recovery

Recent install attempt of /e/os recovery [recovery-e-1.14-r-20230817321316-dev-wayne.img] on a linux machine. MiUI version is 12.02.

Successfully unlocked the bootloader then proceeded to install the /e/os recovery (see below for a listing of commands i used). This seemed to work but when i restarted into the recovery the original Mi recovery v 3.0 was still there.

Any ideas on this. Any help is much appreciated.


$ adb devices
List of devices attached
ab75929	device

$ adb reboot bootloader

$ fastboot devices
ab75929	fastboot

$ fastboot reboot
Rebooting                                          OKAY [  0.000s]
Finished. Total time: 0.201s

$ adb reboot bootloader

$ fastboot devices
ab75929	fastboot

$ sudo fastboot flash recovery recovery.img

Sending 'recovery' (22408 KB)                      OKAY [  0.596s]
Writing 'recovery'                                 OKAY [  0.508s]
Finished. Total time: 1.111s

$ fastboot devices
ab75929	fastboot

$ fastboot reboot
Rebooting                                          OKAY [  0.000s]
Finished. Total time: 0.151s

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @katesfb welcome to the /e/ forum.

My guess would be that the method you are using to leave fastboot mode is causing Xiaomi software to “self protect” and overwrite your new recovery image.


fastboot flash recovery recovery.img

try to shut down the phone from fastboot mode using Volume Down + Power. Keep holding both buttons till the screen goes black, then quite fast initiate the boot of recovery by moving your fingers to Volume Up + Power

Maybe you have to experiment with the key presses a bit to avoid some sequence of actions which is allowing the “self protect overwrite” to happen.

Hi @aibd,
Thanks for the reply, much appreciated.

I did as you suggested and it worked perfectly - thanks for that.

The rest of the install went fine according to the documentation, however when i went to reboot, i still got the Mi logo a couple of times then it went back to the E recovery with the message:

"Cant load android system. Your data may be corrupted. If you continue to get this message, you may need to perform a factory data reset and erase all user data stored on this device"

I have tried to reboot a couple of times with the same result, is it safe to go ahead with the factory data reset or is something else going on?

Any help is much appreciated.


Factory reset … yes for certain.

Uncertain – but this has been reported a few times.

Some extra information (partly in case the issue does not go away).

The install instructions include

Format the device

On /e/OS Recovery main screen:

  • Select Factory reset
  • Select Format data / Factory reset option

Were you sure to do exactly that ? It is essential.

Furthermore, I always make sure that I prepare the device for install by

  • removing all accounts especially Google and
  • factory reset the device on its original Android version.

I want no hangover of anything Google.

Would you consider going back to the beginning ? No, not unless you think you might have left the Google account on the phone, it can survive a Factory reset.

If there might be “something else going on” it might stem from this.

Alternatively, it is a known issue that on rare occasions First boot is “not quite successful”. On these occasions a reboot or Factory reset can be required just to get the device going.

Hi @aidb,
And again thanks for the reply

OK i have made progress and you were right about the accounts left on the phone - there was probably at least a google account even though i didnt use it and a Mi account.

Given that the phone would always boot to the Mi logo and then the E recovery screen i wasn’t sure how i was going to remove the google and any other accounts but a bit of research revealed that Xiaomi recommend the command:

fastboot -w

to remove user accounts. The response to the command was:

Erasing 'userdata'                                 OKAY [  0.938s]
/usr/lib/android-sdk/platform-tools/make_f2fs failed with status 1
fastboot: error: Cannot generate image for userdata

However i am not sure what the last two lines actually mean. I tried the same thing on a windows PC which had more information about what had been wiped and setup and did not have the fastboot error.

When i rebooted it went to the Mi logo for a couple of seconds then went to the ‘e’ logo with the bouncing dot underneath however this is as far as it got and although i left the phone for about 20 minutes it did not progress from there and as the phone was starting to get a bit warm i attempted to turn it off which didn’t work as it kept going back to the ‘e’ logo, eventually i managed to get the phone back into recovery mode and was able to turn it off from there.

When the phone didnt install properly and booted to the e Recovery, there was a message down the bottom “installation completed with status 3, installation aborted”

I decided to re-apply the update - The following is a listing of what i did plus an image of the process from the phone:

$ adb devices
List of devices attached
ab75929 recovery

$ adb sideload e-1.15-r-20230916331434-dev-wayne.zip
Total xfer: 1.00x

So, i had another go at applying the update process but again it simply went back to Mi logo and then on to recovery with the “cant load Android system…” message.

Tried to do the exact same thing from windows however the result was the same.

Could the e OS image i am using be actually corrupted? I got the image from the main repository on the /e/os site so should be OK?

Any help is much appreciated.


I think you should go back to Xiaomi original and do a full clean up of accounts and Factory reset from there.

You might use the “tool” which you first used to unlock the phone to reinstall Xiaomi original at the Android version of the /e/OS ROM.

Hi @aibd,
I decided to have a crack at installing lineage 18.1 (android 11) on the Mi 6X (instead of reinstalling the original) and it worked which is interesting given that the instructions for both are pretty much the same.

The only thing i did differently was that after the install completed and i rebooted (which resulted in the reboot getting stuck again during the reboot process), i stopped it by rebooting into recovery mode and then rebooted into the boot loader and ran the command:

fastboot -w

This time a lot more information was produced compared to when i used this command prior to the install process (see above) and then when i rebooted from fastboot mode:

fastboot reboot

About a minute later i had a fully operational lineage OS. I am working through checking that everything seems to work and so far so good. It seems to me that this method would also work for e/OS if the reboot after install gets “stuck” but for the moment i will stick with lineageOS as it seems to be working fine.

Again thanks for all your help.


This topic was automatically closed after 90 days. New replies are no longer allowed.