Xiaomi mi 8 installation problems

hi, i recently bought a xiaomi mi 8 i tried to install the rom eelo but when i sideload adb i get the following message:

ERROR: This package requires firmware from from MIUI 9.6.20 developer build or newer. Please upgrade firmware and retry! updater process ended whith ERROE: 7

Can someone help me, thanks

Flash first the requested firmware

Thanks i go to try it.

sorry for the trouble, but i stuck in fastboot, would you have a tip to solve?

when ? When installing new firmware ??

Have you downloaded the last one ?

Device Codename Branch MIUI Android Region Link Updated
Mi 8 dipper weekly 20.9.4 10.0 China 2020-09-05
Mi 8 dipper stable V12.0.1.0.QEACNXM 10.0 China 2020-07-31
Mi 8 dipper stable V11.0.5.0.QEAMIXM 10.0 Global 2020-07-16
Mi 8 dipper weekly 9.6.27 9.0 Global 2019-06-28

Showing 1 to 4 of 4 entries (filtered from 291 total entries)

I blocked it while trying to put miui 10 for android 9 luckily I was able to fix.i solved it with the fastboot rom on this site:

i leave it so someone else can solve my same problem.
Thanks for your help

1 Like

thx for sharing and happy to hear that it is working now

Thanks for your help, I was finally able to download the new system. I can ask you if it is normal that there are apps like play store, facebook, amazon, aliexpress and opera

In the Miui. … yes, but not in eOS

I repeated the operation and the problem
it resolved. Thank you very much for your help, without you I would never have succeeded, thanks again.

1 Like

It was me a pleasure :smiley:
Enjoy eOS :+1:

I had similar problems during installation but i could solve it:

First to say: I bought a brand new xiaomi mi 8 dipper. I followed the /e/ foundation instruction step by step until I got an error with “adb sideload” for the e-package. The console on twrp displayed something like “install firmware newer then 19.6”.

So my first thought was I could solve it with the latest firmware from https://xiaomifirmwareupdater.com/ and tried to “adb sideload” the new firmware. But then the twrp console displayed the error “xiaomi verify_modem failed to read current MODEM build time-stamp: 2”.

So I decided to try an older firmware, a one that matches the /e/-os-version and that finally worked. (fw_dipper_miui_MI8Global_V11.0.6.0.PEAMIXM_45261e66d2_9.0.zip was the firmware that worked form my dipper).
Here is the download https://xiaomifirmwareupdater.com/firmware/dipper/stable/V11.0.6.0.PEAMIXM/

I have also to notice: I couldn’t install /e/-os via sideload, so I copied the .zip onto the storage and went to install on twrp and chose file from file storage.

I hope I coud help other people here in case they ran into similar problems.


Thanks to this post I have been able to install / e / on my Xiaomi Mi8, but I have a problem with the bluetooth that has micro-cuts when I play music.