XIAOMI MI MIX 2S... need help for V12.0.3.0.QDGMIXM upgrade (from V12.0.1.0)


First Xiaomi, for e/ only… I have a PC under windows 11.

Easy step to date was Unlocking the bootloader, following Xiaomi guides,

I also succeeded in installing TWRP (but Volume up + power goes to Xiaomi Recovery with Reboot only possibility…)

I currently struggle in the step to update current Xiaomi ROM from V12.0.1.0 to V12.0.3.0.QDGMIXM… as it is not automated from the phone

1st try using Mi flashtool

  • was installed
  • never worked

2sd try using fastboot

  • I copy the .ziP in “platform tools” directory
  • the device was recognise
  • adb reboot sideload
  • adb sideload miui_MIMIX2SGlobal_V12.0.3.0.QDGMIXM_13c81516b3_10.0.zip
    Did NOT work

3rd try:
I reinstalled TWRP (+ data wipe), stayed on TWRP
I connect the phone to the PC, was able to see it but not to copy any file

I am sure it is so simple that nobody needs tuto… reason why surrely the e/ documentation mentionning the required version v12.0.3.0… does not say how to upgrade… But I do need help… so if anybody have an explanation or website providing clear explanation he/she will be very welcome

Many thanks

Have a good week end


At first, you don’t need to install a full stock ROM, as you will replace it with /e/OS :wink: . Firmware is all you need here.

I’m not sure how to flash the file you have, as it is not officially available anymore and you didn’t specify from where you got it.

Let’s stay with firmware only. You can get it from here: https://xiaomifirmwareupdater.com/firmware/polaris/stable/V12.0.3.0.QDGMIXM/. Also please read their FAQ.
For an easy use, please download it to the same folder you have adb.exe installed.
Installing this firmware is achieved by the exact same procedure as any ROM file:

  • (re)boot device to recovery (Xiaomi, TWRP, LineageOS, /e/OS, OrangeFox, whatever). As you have TWRP (you didn’t mention the version), let’s go with this one!
  • plug the device to your computer, then issue adb.exe kill-server then adb.exe devices: it should reply with an ID, followed by “recovery”.
    – note 1: for some devices and/or TWRP releases, it may take up to 10 minutes for the device to connect and get recognized by the computer
    – note 2: if after 2 cups of your favorite beverage the device is still not available, in TWRP go to “Mount” then try to play with MTP button (for one device I have to disable then enable, every time)
  • 2 ways to go from here:
    – 1/ easy way (untested by me, but reported to work fine):
    — in TWRP home screen, go to “Advanced”, then “ADB Sideload”
    — on computer, issue adb sideload fw_polaris_miui_MIMIX2SGlobal_V12.0.3.0.QDGMIXM_13c81516b3_10.0.zip
    – 2/ safest way (the one I prefer)
    — on computer, issue adb push fw_polaris_miui_MIMIX2SGlobal_V12.0.3.0.QDGMIXM_13c81516b3_10.0.zip /sdcard. This will transfer the zip file to device internal storage
    — in TWP main screen, use “Install”, navigate to /sdcard, select the zip file then confirm by swiping
  • you can follow the flashing on TWRP, if I remember well it should display “Flashing Normal Firmware …” and “Target: Xiaomi/polaris/polaris:10/QKQ1.190828.002/V12.0.3.0.QDGMIXM:user/release-keys”, then start flashing 16 partitions
  • reboot to TWRP (recovery), then continue with /e/OS installation as instructed in documentation

Hope this help & clarify!

Finally find the solution vie MiFlash:

  1. use MiFlash 2020.3.14

  2. use unzip .tgz ; NOT .zip file provided
    you can find .tgz here :
    See MI MIX 2S POST
    provided by @e.follower

  3. the unzip file has to be in C:\xiaomi

Then follow MiFlash too tuto

Next step is e/…


I see where i was wrong… Find the way using MiFlash but thank you for your answer which can surrely help other.

Have a good day

1 Like

For the reference: if source file (.zip, .tgz, whatever) is not in the same directory as adb.exe or fastboot.exe, you can specify full path enclosed in " ".
For example
adb sideload "D:\MyFiles\Download\Xiaomi firmwares\fw_polaris.zip".

All done succefully

Using fastboot boot recovery instead of Volume up + power to avoid the MI recovery.

This can be now closed

Thanks again @smu44 for your help

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.