Xiaomi Mi8 Upgrade to S without losing data?

My Xiaomi Mi8 (dipper) got stuck on Android R Ver. 1.8.1. To get newer Versions I should upgrade to Android S.
Is there a way to not to lose all my data (to reset my phone)? Anyone upgraded succesfully a Xiaomi device without losing all data?

If not, is there a way to backup all Android-settings at once? (Apps and Data are another thing…)

Thanks for your support

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online services![phone|80x80](upload://mtacZf1KIgDZJegjO3jnRNYJDPg.png

I upgraded sucessfully my MiMIX2 from R to S without any data loss.
Not before taking a complete backup before, of course :wink:

But this may vary from one device to another… Worth a try!

As for backup: currently there is no easy solution for complete backup.
I’d advise to search here for:

  • copy personal files to PC
  • backup SMS/MMS & calls
  • TWRP or script-based backup (don’t forget to remove lock pattern/ password, this will remove encryption)
  • some apps may provide proprietary solutions
  • as last resort, if you have Murena Cloud linked, you may find a text file with a list for your installed apps

Sorry I’m on the road, no links.

Oh wow! This gives me some hope! :sweat_smile:
Because the Mi Mix2S is the second device I should upgrade…
But how did you upgrade, as OTA is not possible? Sideload? Did you follow a manual?

Yes! Manual upgrading of /e/OS without data loss is identical LineageOS

I personally don’t like sideload method and the strange false error it gives :wink:
So I downloaded the ROM image using Browser, then rebooted to TWRP recovery and use it’s Install function (navigating to /sdcard/Downloads).
All /e/ ROM images are available here: https://images.ecloud.global/dev/xxxx/ (replace xxxx with you device codename, dipper or polaris).

Any method you will use, don’t forget to clear cache & Dalvik.

As a side note, latest firmware images are available here: https://xiaomifirmwareupdater.com/firmware/xxxx/ (replace xxxx with you device codename, dipper or polaris).

1 Like

I did it as you described! And it worked like a charm. I was a kind of nervous… :face_with_peeking_eye:
Thanks for you all your recommendations, guys!
Magisk seems to be broken. But as long this is the only bad thing happened, I am happy!

Nice to read that @Co_chise :smiley_cat:

Yes, the TWRP upgrade variant is a good alternative to the adb sidelaod variant, unless you use the e-recovery offered by /e/.

But also with the ‘dipper’ e-Recovery an upgrade can be done without an additional PC only on the smartphone. Only a USB stick is needed.

Download the /e/ROM to the Mi8 using the e-Browser, then move/copy the ROM to the USB stick, so then boot into the /e/Recovery and then initiate the upgrade via > Apply update > Choose from USB stick.
The disadvantage of this method: e-Recovery is not updated, although the file recovery.img is included in the compressed rom.zip. In this case the current e-Recovery must be installed via fastboot.

What are these strange errors?

I’m wondering if the upgrade could work from a one-time boot to TWRP, having e-Recovery installed ?

Most often the “Xfer 1.00x” at 47%, but also USB timeouts reported by some users.

I think that upgrading from a image stored internally in device is the safest way.

Hi @smu44, my motto is: the proof of the pudding is in the eating. That’s why I just tested it.

Starting point:

  • e-1.10-s-20230413279105-dev-dipper
  • e-revovery V1.10
  • three additional apps for the purpose of checking if and what happens with it.

Then: reboot into fastboot mode
now: fastboot boot twrp-3.7.0_9-0-dipper.img

Note: dipper /sdcard = files are encrypted, so only the USB-OTG stick variant works for me.

  • in TWRP > Mount USB-OTG
  • in TWRP > Select storage USB-OTG (stick)
  • in TWRP > Install > e-1.11-s-20230511288805-dev-dipper.zip from USB-OTG (stick)

Swipe to confirm Flash
Reboot System

Since this procedure did not update e-recovery V1.10 either, e-recovery V1.11 has to be installed afterwards via fastboot.

… or better …

  • in TWRP > Mount USB-OTG
  • in TWRP > Select storage USB-OTG (stick)
  • in TWRP > Install > recovery-e-1.11-s-20230511288805-dev-dipper.img to /recovery from USB-OTG
  • in TWRP > Install > e-1.11-s-20230511288805-dev-dipper.zip from USB-OTG (stick)

Swipe to confirm Flash
Reboot System

Remüsee: The update worked for me. The three additional apps remained.

Happy updating / upgrading!

1 Like

Nice piece of cake, thanks @Gianna :smiley_cat: