Xiaomi - POCO F3 / Redmi K40 / Mi 11X - alioth - Documentation Suggestions

Not really bothering. Just thought you are too lazy to read. I don’t know what you mean with “there is a location for the phone” but it doesn’t matter anyway. As long as you simply follow what the form is telling you, you will do the right thing.

Sorry my english is terrible.
The phone is global, but there is POCO F3 Turkey - V13.0.1.0.SKHTRXM
So I think, what is better, apparently I won’t wait for an answer from /e/team :frowning:
P.S Thank you for your guide, which I have read many times

My answer will always stay the same: Download the firmware that this form is telling you and then simply follow my guide. Product Authentication

Thanks, I’ll do backup and go…

Let’s start testing…


here is my experience with upgrading my Poco F3 from 1.5-r to 1.5.1-s :

  • I first read carefully the LineageOS documentation and the fBSMT’s guide to see what to do in my configuration.
  • I Made a backup of data.
  • I Downloaded :
    • in my case, the EEA version of firware from LineageOS
    • e/OS/ v1.5.1 S buid (e-1.5.1-s-20221102231515-dev-alioth.zip + recovery)
      Verified with sha256 file
    • Latest release of payload dumper : Releases · ssut/payload-dumper-go · GitHub
  • Already had :
    • Phone charged at more than 50%
    • Linux PC powered by power supply
    • adb/fastboot platform on local directory
    • e/OS/ recovery installed on the phone
    • USB debugging activated

Extract payload for firmware upgrade :

...:~/Data/eOS/alioth$ mkdir payload-dumper-go_1.2.2_linux_amd64
...:~/Data/eOS/alioth$ tar xvf payload-dumper-go_1.2.2_linux_amd64.tar.gz -C payload-dumper-go_1.2.2_linux_amd64
...:~/Data/eOS/alioth$ mkdir Extracted
...:~/Data/eOS/alioth$ ./payload-dumper-go_1.2.2_linux_amd64/payload-dumper-go -o Extracted/ miui_ALIOTHEEAGlobal_V13.0.6.0.SKHEUXM_c393876947_12.0.zip
Please wait while extracting payload.bin from the archive.
payload.bin: /tmp/payload_795040555.bin
Payload Version: 2
xbl_config (102 kB)     [============================================================================================================] 100 %

Power Off the phone
Press Power + volume Down to go in fastboot mode
Connect the usb cable and verify connection with “sudo fastboot devices”

Flash firmware :

...:~/Data/eOS/alioth/Extracted$ sudo ~/Data/platform-tools/fastboot flash abl_ab abl.img
Sending 'abl_ab' (204 KB)                          OKAY [  0.014s]
Writing 'abl_ab'                                   (bootloader) Partition abl_a flashed successfully
(bootloader) Partition abl_b flashed successfully
OKAY [  0.037s]
Finished. Total time: 0.091s

Plus all the other files mentioned by fBSMT and LineageOS, for a total of 17 files.

Update recovery :
Here, I had a problem I didn’t understand :

...:~/Data/eOS/alioth$ sudo ~/Data/platform-tools/fastboot flash recovery recovery-e-1.5.1-s-20221102231515-dev-alioth.img 
Sending 'recovery' (196608 KB)                     OKAY [  4.824s]
Writing 'recovery'                                 FAILED (remote: '(recovery_b) No such partition')
fastboot: error: Command failed

In recovery it’s written : “Version 1.5 () Active slot: b”
So, on one side, ‘(recovery_b) No such partition’ but on the other side, “Active slot: b”.
I supposed that the recovery was not updated…
I decided to go to recovery to continue :

...:~/Data/eOS/alioth$ sudo ~/Data/platform-tools/fastboot reboot-recovery

In e/OS/ Recovery :
Select “Apply Update”
Select “Apply from ADB”

On the PC :

...:~/Data/eOS/alioth$ ~/Data/platform-tools/adb sideload e-1.5.1-s-20221102231515-dev-alioth.zip
serving: 'e-1.5.1-s-20221102231515-dev-alioth.zip'  (~47%)    adb: failed to read command: Success

Mmm, “failed”, but “Success”.
OK, we’re getting used to it and there are no error on recovery screen, so let’s continue.

Select “Reboot system”
The phone is restarting

e/OS/ 1.5.1-s was installed !
Android 12, Android security update : oct 5, 2022, Vendor security patch level : Aug 1, 2022

The first thing you see is there are a lot of visual changes.
And after a quick look of my apps, messages, special configurations, etc, it seems that I have not lost anything.


1 Like

Hello, I also did everything according to the instructions of the respected fBSMT.
I put “POCO F3 Global V13.0.3.0.SKHMIXM” because I have a global revision, did not experiment and set it according to the region of location.
Flight is normal. Only sometimes touching is not always clearly recognized, perhaps the Nillkin protective glass is to blame

1 Like

Hey! Congratulations for successfully upgrading to eOS S!

Regarding the recovery:
On A/B devices recovery isn’t a separate partition but actually included into the boot partition. So it’s impossible to flash recovery separately. It is updated by flashing the normal eOS ROM. The recovery image files provided are only there for temporarily booting into them, the same way I boot into TWRP in my guide. sudo ./fastboot boot reoveryfile.img

Unfortunately I can’t edit the post containing my guide but if e-foundation ever allows me to add my guide to the official documentation I will add a notice regarding the nature of recovery on A/B devices, so people don’t get confused. Thanks for sharing your experience so I could learn about this potentially confusing detail.

Hey Test_user! Glad to hear that your upgrade to Version S was a success and I am happy that you used my guide to do so! Have fun!

Updated to e-1.6-s-20221130239247-dev-alioth from e-1.5.1-s-20221102231515-dev-alioth.zip, updated for 10 minutes, but so far everything is fine …

I manage using fBSMT’s guide to do a first time install on a brandnew Poco F3.
The stock Rom was too new, I had to revert to the above mentioned rom.
The guide in the documentation didn’t work.
Kudo’s for fBSMT!

1 Like

Hey @Gaea thank you so much for the kind feedback! You are correct! The guide for first time setup should definitely be updated as well to include the correct ROMs depending on the users device region. Lineage 19.1, which eOS is ultimately based on, does require very specific firmware releases to work (properly).

@Manoj you and the team are doing a fantastic job and Murena devices absolutely must have priority, since they are funding everything. Also I assume you guys are way understaffed and overworked. I understand that ALIOTH is very low priority. But please consider that the official eOS install and upgrade guides incorrectly tell users to upgrade their ROM to the newest MIUI dev version, which results in people being unable to install eOS 1.6 or worse, their phone having malfunctions. eFoundation does not earn money from POCO F3 user, however I decked out my entire family and my girlfriend with Murena Store bought Gigaset GS290 phones after I successfully tested eOS with my Nexus 4 and Mi Mix devices back when I first discovered eFoundation. Providing outdated documentation damages eFoundation/Murena!

At the very least, can you guys please add a big red warning box on top of all ALIOTH guides telling people that the guides are outdated and they should either consult this thread or wait until the documentation has been updated? I rather spend the time guiding individual users through the initial installs and upgrades (should my guide not suffice) than having people go through a very negative first experience with eOS which causes them to never come back and recommend others against eFoundation/Murena.

I wish you and the team a successful 2023! :fireworks: :sparkler:

The “official” guide for alioth install has been updated to reflect the required firmware before install, so this seems to be fixed. But just followed the guide step by step and still does not work, because the e-os v1.6s (which is referenced) is still considered a downgrade and adb sideload through recovery will fail. But the e-os testing version 1.7s works fine (I think this is because it uses the newer Android Security Parch, but could be wrong). If anyone from the team is interested, I have a device I can use for further testing

In the /e/OS release notes Releases · e / os / releases · GitLab we are told that in e-1.6 Android is updated to 5 Oct 2022. There are no release notes for 1.7 today (“release candidate” dropped yesterday, I think).

In my device running e-1.7-r-xxx I see in

  • About phone > Android version

Android security update 5 November 2022.

You might check Android security update on your control phone against your e-1.7-s-xxx device.

Maybe this information will help users who follow to avoid installing /e/OS on a device where the “Stock” manufacturer build is in advance of the available /e/OS (if it is as simple as that).

So did some more testing and here is the exact error (when using the lineage OS vendor_boot mentioned in guide):

Current SPL:2022-12-05 Target SPL: 2022-10-05 This is considered a downgrade
Denying OTA because its SPL downgrade

And I think it is only connected to the “vendor_boot.img” you flash, NOT the actual OS on the phone. I tried it with vendor_boot extracted from the /e/OS “e-1.6-s-20221130239247-dev-alioth.zip” and the error was the same (just current SPL date changed slightly…), but using older vendor_boot.img from “e-1.5.1-s-20221102231515-dev-alioth.zip” worked fine, since it was not a downgrade anymore.
So two suggestions/questions:

  • Why use Lineage vendor_boot.img when /e/OS vendor_boot seems to work fine (you also get /e/OS as the the initial recovery, not having to flash throught the Lineage recovery)?
  • Always provide vendor_boot with older SPL than the current full image, so you avoid the downgrade error

If anyone can veryfi this, I would be thankful.

Found this guide very helpful. I wanted to add a few items to help others as it was not a straight forward install. I have fair amount of experience flashing but minimal coding experience. I do use the ADB method generally.

The install guide was confusing as it has added the need for installing additional partitions but the exact files and how to flash is not entirely clear.

I have found the following steps useful for installing on my POCO f3 - GLOBAL - on 13.0.6 rom.

Install SDK and use platform tools for adb commands - I use windows powershell.
Use Mi account to unlock bootloader -I had to wait one week. Developer options worked.

I tried many steps to install and flash but could not manage the partitions. I even managed to extract using payload dumper go and tried flashing as described above but kept getting stuck at partition changes and ended up back in the original rom. I was happily boot loading into fastboot.

I noted that partition issues are supposedly less of a problem with the latest TWRP.

Therefore, I downloaded TWRP from sourceforge for android 13:

I installed this onto my poco f3 using adb commands and followed this video:

I ended up with a chinese version of TWRP so used this video to set to english language - just search on youtube

THEN reading through I did an advanced WIPE of data, dalvik, data, cache.

Then I stayed in TWRP and used the ADB SIDELOAD function. Once I started the adb sideload on the phone then used powershell in windows to adb sideload e-****.zip (replace the filename with your version of eOS you are installing).

THIS CAUSED THE a/b problem to occur as it installs on empty slot b - on the TWRP is advises to reboot to recovery. So when it reboots it loaded eOS recovery 1.7. It says that you need to enter this recovery to switch to slot B.

I stayed in this recovery (it says it is on slot b) and found the adb sideload function again within eOS recovery. Then did the same process and adb sideload e-***.zip file again into slot B using eOS recovery 1.7

Then rebooted and eOS was loading. I presume I am now in slot b. No idea if the original is still in slot A. When I reboot to recovery it is eOS recovery 1.7 and now says slot A.

It will reboot to recovery and fastboot etc.

Just a quick update to say how I managed to get eOS installed and did not use most of the steps above.

Hi all,

I am trying to install /e/OS (e-1.11) on my POCO F3, but it is not working. When I followed the official documentation I got an error (recovery: Signature verification failed / error: 21) during the adb sideload step. I also tried the TWRP solution proposed by @fBSMT but also got an error (Error applying update: 7 (ErrorCode:: kInstallDeviceOpenError) Updater process ended with ERROR: 1).

Did someone manage recently to install e-1.11 on POCO F3, who can give me some advice.

Thank you very much in advance.


I would like to install e/os. Currently I have MIUI Global 14.0.9 on my phone.

  1. must this “POCO F3 Global - V13.0.3.0.SKHMIXM” Rom be installed on the phone or is it also possible with my current Rom.
  2. there is always talk about update, are all the steps also necessary for a new installation.
  3. after a long time of trying i managed to extract all the vendor-blobs from
    “POCO F3 Global - V13.0.3.0.SKHMIXM”.

Please answer the previous questions so I am sure what the next steps are for me.

Thanks and greetings

P.S. Is translated with deepl because my English is not so good. I hope it is understandable.


as the T version is available (https://images.ecloud.global/dev/alioth/),
does someone already tried to upgrade from S version ?


Well, I started with the T version update

I first made backups.
Then I read the documentations from :
e.foundation : https://doc.e.foundation/devices/alioth/install
Lineage 0S : https://wiki.lineageos.org/devices/alioth/upgrade/variant1/ and https://wiki.lineageos.org/devices/alioth/fw_update/variant1/

In Lineage OS upgrade documentation for 19 to 20, it’s needed to flash firmwares, so I will do that.
It’s similar to the previous upgrade from Android 11 to Android 12.

1 - Let’s get all the files needed.

I took the mui rom file directly from https://xiaomifirmwareupdater.com/archive/miui/alioth/
As I have an european model, I took “miui_ALIOTHEEAGlobal_V14.0.7.0.TKHEUXM_4f54362c0d_13.0.zip”
Read the LineageOS doc for your device version !!!

Get payload-dumper-go at https://github.com/ssut/payload-dumper-go

Get e/OS/ files e-1.20-t-20240221382228-dev-alioth.zip and recovery-IMG-e-1.20-t-20240221382228-dev-alioth.zip

And I verified the checksum for all files.

2 - Extract

The payload and recovery zip.
./payload-dumper-go_1.2.2_linux_amd64/payload-dumper-go -o Extracted/ miui_ALIOTHEEAGlobal_V14.0.7.0.TKHEUXM_4f54362c0d_13.0.zip
unzip recovery-IMG-e-1.20-t-20240221382228-dev-alioth.zip

3 - Flash files
In fastboot mode, flash :
From payload :
fastboot flash abl_ab abl.img
fastboot flash aop_ab aop.img
fastboot flash bluetooth_ab bluetooth.img
fastboot flash cmnlib_ab cmnlib.img
fastboot flash cmnlib64_ab cmnlib64.img
fastboot flash devcfg_ab devcfg.img
fastboot flash dsp_ab dsp.img
fastboot flash featenabler_ab featenabler.img
fastboot flash hyp_ab hyp.img
fastboot flash imagefv_ab imagefv.img
fastboot flash keymaster_ab keymaster.img
fastboot flash modem_ab modem.img
fastboot flash qupfw_ab qupfw.img
fastboot flash tz_ab tz.img
fastboot flash uefisecapp_ab uefisecapp.img
fastboot flash xbl_ab xbl.img
fastboot flash xbl_config_ab xbl_config.img

Restart and return to fastboot :
fastboot reboot fastboot

From recovery zip :
fastboot flash vendor_boot vendor_boot-e-1.20-t-20240221382228-dev-alioth.img
fastboot flash boot recovery-e-1.20-t-20240221382228-dev-alioth.img

4 - Upgrade in recovery
Restart in recovery then go to update and update from adb :
On computer, “adb sideload e-1.20-t-20240221382228-dev-alioth.zip”

5 - Restart system
Check you’re on Android 13.

I did not noticed problems so far.