XIAOMI Redmi 4x: Some installation process changes?

I recently got a “refurbed” phone XIAOMI Redmi 4x and installed /e/.
I found out, that a few things might have changed, according to the original installation routine on the official website.

Points to consider/That might have changed:

  1. Unlocking my XIAOMI phone did only work with inserted SIM-Card and inserted SD-Card.
  2. The Xiamo-account had to be with a phone-number. Email did not work.
  3. On my refurbed phone I did not have to wait for 72 hours to unlock. I could directly download the app.
  4. When I reached the final step in the installation process described on the website I got the message “NO OS DETECTED.” Solution: I copied the /e/image onto the sd-card. Then I selected inside TWRP “install” and “from image”. That did work

Maybe this helps other as well…

Hi !

Thanks for your share :slight_smile:

But it didn’t goes the same for me last week (I reinstalled latest stock ROM after some testings) :

  1. I didn’t need a SD-Card inserted, just a SIM-Card with active data
  2. Unlock worked fine with my email (and the phone # of SIM-Card wasn’t the one registered at Xiaomi)

About 4 : I’ve seen this message before (not last week), I decided to reboot anyway and it worked fine.

Such differences are confusing, maybe all Xiaomi accounts are not identical, based on country or something like ?

Hello smu44,
I think, your thoughts are right. Probably there are slight differences based on country, or version of the phone. That is why I described my “showstoppers”. I think it is good to know and describe that different things can happen… Because every describtion of any “might-happen” helps newbies like me to feel on the correct installtion-path…

1 Like