Xiaomi Redmi Note 7 Pro installation issues

Hi All,
I am installing e for the 1st time. I have followed the directions here:

I have successfully
unlocked the bootloader
run: fastboot flash recovery twrp-x.x.x-x-violet.img
run: fastboot boot twrp-x.x.x-x-violet.img

However the following step: Now reboot into recovery to verify the installation.
is not clear to me. The phone has rebooted several times but always back to a Xiaomi phone set up.
Am I missing something?


Sorry, I’m a little confused, The Redmi Note 7 Pro is a xiaomi device and not a OnePlus. or am I wrong ??

This is an alternative command, if the

not working.
with ‘fastboot flash recovery twrp-x.x.x-x-violet.img’
you are flashing twrp on your device

with ‘fastboot boot twrp-x.x.x-x-violet.img’ you are booting temporary into twrp

After flashing TWRP you have to boot in recorvery with the hardware buttons “Volume up + Power”

This is what I was missing:

After flashing TWRP you have to boot in recorvery with the hardware buttons “Volume up + Power”

Thanks :slight_smile:

welcome. Hope now will work everything :slight_smile:

Thanks Harvey,

I now have:

falling back to older sideload method…
terminate called after throwing an instance of ‘std::bad_alloc’
what(): std::bad_alloc

perhaps the TWRP recovery image did not work properly. I have a screen showing “Teamwin” but no buttons.
any ideas?

wondering if its a corrupt zip file. I’m downloading another

Are you sure you have the Xiaomi Redmi Note 7 Pro (violet) and not the Xiaomi Redmi Note 7 (lavender) ?

pretty sure its the pro


Just in case you run into similar issues I used THIS version of TWRP: recovery_twistloop.img

Hope that helps.


1 Like

Hello everybody.
First install of a custom ROM for me, i cant tell what im doing wrong, followed the steps exactly.
Cannot get pass the flash recovery part. After fastboot flash recovery twrp.img* and reboot to recovery, the TWRP screen loads but no buttons or commands appear. Only the TWRP logo. Used adb reboot recovery command , tried entering recovery using volume and power buttons but the same result. Can someone please guide my steps ? (for Redmi 7 pro)

Hello. After intense googleing (sorry… ) i discovered this post:
so i used the “unofficial build” to bypass the decryption problem with the MIUI and
TWRP booted as intended and installation finished ok! (except the error 7 problem which was presented in multiple threads on this forum).