Xiaomi whyred flashing recovery doesn't work

Hello,
I tried to install /e/ on my Xiaomi Rednote 5 (whyred) but installing TWRP seems not work.
I followed every first steps of the install manual : https://gitlab.e.foundation/e/wiki/en/wikis/device/whyred/install

here a screenshot from my terminal
recovery

The first try was KO because i try to flash revovery but the second time, flashing seems to be ok (sending OK, writing OK)
But when i reboot in recovery mode with adb reboot recovery, it’s still Mi-recovery and not TWRP.
I didn’t realize that and wipe all my datas (I was disapointed that backup was not available but i was confident) and now i have a reinitialized phone like it was just out of the box :frowning:

Does someone sees i did something wrong ?

Thanks

Hi @Finkelstein,
On my MiA1 I do the following after I have successfully flashed /e/ ROM and checked it is working

  • adb reboot bootloader
  • fastboot devices
  • fastboot boot twrp.xxxxx
    This would open up the twrp screen
  • adb push twrp.xxx.img /sdcard/
    There from within the TWRP UI Install
  • Click Install image button and browse to the twrp img file
    flash it to the Recovery ramdisk option I see in my version of TWRP. It could be named different for other versions
    Then once the flashing is done reboot system
    Now when I try to reboot to recovery I come to TWRP and not the default recovery

Hi,
I had a similar problem when flashing /e/ to my Mix 2 (chiron).
I gave the LineageOs method (link provided at bottom of /e/ wiki page) a try, it worked nice.
Didn’t took the time to compare both methods …

hello @Finkelstein, here’s a tutorial to flash a recovery, “orange fox” in this case, to whyred. the procedure would be the same for TWRP. this tutorial is similar to what @Manoj did.

The whyred wiki part on flashing a recovery needs to be updated. as it doesn’t work the way explained over there, and it could be frustraing.

Thanks to all of you.
I’ll try @Manoj procedure next time and keep you in touch

Hello again,
I try many things but the smu44 method (lineageOS method) works : i boot on TWRP but it asks for password and i don’t know this password.

I tried

  • my PIN code
  • i use a pattern to unlock my phone, i tried this pattern converted with numbers : it doesn’t work
  • i’ve done a factory reset to set a number password and tried this new password : it still doesn’t work

I have no more ideas and without password I can’t access to any storage to do backup (i would like to do system backup if e is not working or i don’t like it).
Please help

I had a pattern security scheme set up within the Xiaomi stock OS, no password.
When entering TWRP (the “mount” screen), I choosed 3x3 and drawed my pattern. No password asked.
Maybe a TWRP problem, did you search their wiki/forum ?
Are you sure you are using latest 3.3.1.1 ?

many thanks @smu44
I wiped all my data and it break the encryption and then i was able to delete cache and system with advanced wipe, but i wasn’t able to sideload !!!
I was affraid but for my last chance i tried twrp 3.3.1.1 (i was using twrp 3.3.1.0), and all went well and now e is on my phone.

That was quite an adventure but it finally ends well.
Thanks to all of you !

1 Like

Hi,
I’m glad to read this happy end :blush:, congratulations Finkelstein !
Obviously the wiki needs revision, but I couldn’t figure how to get editor access. So if a maintainer is reading this thread …

1 Like

Thanks for pointing error in the wiki. Will pass it on to the team and request that the updates are made.

@rhunault F.Y.I some updates are needed to our wiki as per this thread.

Thank you to report this issue. Could you please raise an issue on https://gitlab.e.foundation/e/wiki/en? Thank you in advance! :blush:

Romain

Hi !
Just submitted the issue : https://gitlab.e.foundation/e/management/issues/494 :slight_smile:
Hope I did well, this this my first time with /e/ GitLab issues tracker !