Xperia XA2 freezes with blank screen

Anyone else having trouble with /e/ freezing on an Xperia XA2?
I have recently bought an XA2 (H3113) and put /e/ 1.3 on it. After less than a day of use it freezes while idle and will not wake up no matter what key combination I use or how long I hold the keys. The Leds do not light and the trembler is silent.

The only way to recover is to take the back off and disconnect the battery. It has happened three times now. On the plus side I am getting quite good at getting the back off quickly.

I have tried with /e/ 1.2 as well as 1.3.
My thoughts were that it was a hardware issue, but I installed the Sony stock firmware and ran it for three days without a problem

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Very strange! I’ve just flashed eOS 1.2 R on my XA2 and will let you know how it goes…
Sony stock was Android 9 right?

I have left it running all day today in safe mode with logcat running in the hope of catching the failure. No failure so far, but on previous occasions it has taken around 24 hours.

The only difference from my normal configuration of /e/ is I have been using OpenLauncher instead of the LawnChair I normally use, but I would be surprised if that were the cause of a total freeze.

Thanks for taking the trouble to try it out.

OTA’d to 1.3-r yeasterday. No probs so far. Just installed Open Launcher from apps. Will see how it goes from here.

There’s a few others running XA2’s who I’m sure would have posted in the forum if they had experienced this problem. Looks like it may well be hardware issue as you also suspect. Is it an old battery by any chance? I’ve never experienced it in a phone but I have a laptop that was behaving very strange: draining quickly, charging ok then not and sometimes turning off. I wasn’t convinced at the time that it was faulty battery, but I replaced it anyway and it’s still working fine now.

Also, you said that when phone died you couldn’t get any vibrations on button press. That sounds like it’s just getting nothing from the battery at that moment because, as you may know, this device has an emergency button press combo to either restart or power off the device when you cant do it normally because of bootloop etc. Hold power & vol. up until one vibration is felt and release buttons to force a device restart. Or hold power & vol up until one vibration is felt, keep holding until three quick vibrations are felt and release buttons to force a power off.

So if you can’t do that when phone freezes it kind of supports dead battery at that moment.

I’ll let you know if mine acts up at all.

You might check Settings > Battery > Battery usage.

There have been reports that when Advanced Privacy is misbehaving there is excessive battery use. It might be significant what seems to be using the power. (Maybe unrelated, but I went through a period of battery drain, and the battery use stats were noticeably wrong: this disappeared with an update.)

Batery Bot (Pro) is expected to give a health warning in the event of a failing battery.

A bad battery was one of the things I considered.
It has the original battery, but the battery health is excellent and the freezes have all happened when there was plenty of battery remaining. Also there was no sign the back had been taken off before I bought it so the previous owner does not seem to have had the problem. Still there is always the possibility.
Advanced privacy is not enabled.

The fact that it does not respond to the emergency button combo suggests to me the CPU has halted. Maybe a memory problem?

It has now worked for over a day now in safe mode with the USB plugged in. I have now disconnected USB and am running normally with Bliss launcher.

Thanks for your suggestions.

Yes, OTA to 1.3-r has worked perfectly on mine since it came through a week or so ago. I did think it could be a hardware issue, but if safe mode is working that suggests not.

The fact that you weren’t using Bliss might be the issue, since a non-integrated launcher might have dependencies that could get broken by updates. That’s my best guess. Bliss is the not the fanciest launcher around, but my set-up is so minimal that it hardly matters. Functionality over fanciness, I’d say.

Good luck!

Another freeze. OpenLauncher was not installed so not implicated.

I think it must be a hardware fault. If I can get it to freeze with stock firmware I should be able to return it.
Shame. It was a nice phone.