Xperia XA2 (H3113) and v0.14


I tried to install /e/ os v0.14 on a Xperia XA2 today. After the installation the phone hangs with a black screen during the boot process, also the /e/ logo does not appear.

v0.13 could be installed without problems. An OTA to v0.14 also stuck with a black screen after reboot.

Any ideas what is going wrong?


Hi Christian,

Bad luck with the update. There are quite a lot of reports of problems with v0.14 on the forum. Some have bootloops, some fail to install, etc. So it could possibly be an issue with the update itself rather than problems with your device; hard to be sure. A little more info might help.

So you were on version 0.13 before, and just to be sure, same OS oreo?

You tried the OTA first? That failed, then you tried to install and that failed also? Or was it other way round?

And (sorry for the inquisition :wink: ) what install method do you use?

@christian.roeser, I’ve just installed e-0.13-oreo over a stock android 8 pioneer, booted it, taken the OTA and that has booted up ok too.

I think it might be a slot issue on your phone. This could possibly be resolved with more info on exact steps but the XA2 is very soon going to be updated to Q.

@chrisg Thanks for your help.

I’ll try to answer all the questions, however it’s a bit more “complicated”. :wink: I would like to change to a system that offers more data protection. For this I bought a used XA2 for testing purposes, so I wanted to test Sailfish OS and /e/ os.

The device was delivered with Android 9, this was overwritten with Sailfish OS X. Since I did not like this, I wanted to test /e/ os.

I first tried to install v0.14 according to instructions: boot with fastboot twrp, wipe the device, install system via sideload - 3 times in total, once on slot B as well. Next I copied the zip file to the SD card and installed via twrp, all this resulted in a black screen.

After that I installed v0.13 via sideload, this worked on the first try. After setup I did an OTA update directly, this resulted in a black screen during boot. I then wiped the device, installed v0.13 and performed an OTA update - black screen.

I can live with v.013 and wait for the update. Currently I am testing which of my needed apps are running under e /os/, so far everything looks good. :slight_smile:

Ha ha, I’m running Sailfish (again) on another XA2 at the moment; just to see if much has changed since I was last there about 9 months ago.

Since your device was on android 9 might be worth considering installing the eOS pie test build. This would give you a better experience of what to expect under eOS going forward. I ran this build on my XA2 from August to December 2020 without any real issues.