Xperia XA2 Stuck at the sideloading stage... not sure how to proceed with rooting, either

This is on an Xperia XA2 H4113. Below is context and info that might be useful, actual questions are at the bottom.

Summary

Note: I’d never done any Android customization before. Sadly, things were fucky from the very beginning (and still are).

To start, the “recovery” mode (green LED) doesn’t have a menu with a little android guy, just a black screen. It didn’t seem to matter much though, and I’m always able to use the recovery mode with EMMA and restore the phone to factory settings.

(EMMA is a firmware flasher made by Sony - I was able to restore everything to complete default with it, unlike the firmware I tried from Newflasher. Super easy to use, everything is automatic. EMMA has now been removed from Sony’s site for some reason, but the installer is still archived on the Wayback Machine).

Anyways, the weird lack of recovery screen might be why the command adb push twrp.zip / doesn’t work, and I have to do fastboot boot twrp.img (while in bootloader mode) each time I want to use TWRP.

Something that was quite simple to fix in the end, but had me stumped for a very long time - each time I tried to do a backup in TWRP, it failed. It was trying to do make backup in “data/media/0/twrp” among a bunch of randomly named, encrypted folders. The fix was to open TWRP -> “Wipe” -> “Format data”, which removed the encrypted shit (along with all the saved media, pictures, whatever).

Now that I had a TWRP backup copied to my PC, it was time to install /e/. However, none of the commands such as adb shell twrp sideload or adb sideload e.zip or adb reboot sideload work. Opening TWRP and using “Advanced” -> “ADB Sideload” doesn’t work either - it just stays stuck on the “Starting ADB sideload feature…” message.

I found some thread about “manually flashing” .zips if sideloading doesn’t work, but I’m not sure how to proceed here (I have a MicroSD card I could use, though?).

I’m also not sure how I could integrate rooting with Magisk during this install process, if that’s even possible. Is Magisk even the best rooting option? Maybe AddonSU?

Help?!1??one11?!

Hi @chucktingle have you followed the instructions as provided here. On Magisk there was some reference available on this post

@Manoj Yes, those were the instructions I attempted to follow. I also looked at the LOS install guide those instructions were based on. Except when I got to the sideloading part, it didn’t work for the reasons stated in the OP. The adb command doesn’t seem to detect the device, and the TWRP “ADB Sideload” feature just stays stuck. How do I proceed from here? Some sort of manual install from storage/SD card?

Thank you for the Magisk guide, I’ll keep it mind once I figure out how to get an OS going. Which root method do you recommend - Magisk, or AddonSU, or something else?

The most important question is: do you have TWRP installed on your phone yet.
If you dont, probably someone else needs to give advice.

If you do, then u can download the /e/os.zip file with your phones web browser, then move that .zip file to your phones external SD card.

Once you have done moved the /e/OS.zip to your phones external memory card

Restart phone into theTWRP recovery console maybe best to do a backup old your oldOS (in case there is issues), choose SD storage and create a backup (was about 6gb for mine tho sizes can vary for different phones)

On the TWRP menu

  1. Tap the Backup button to create a backup of your old OS. will take a few mins Make sure the backup is created in the external sdcard the internal storage will then be formatted…
  2. Go back to return to main menu, then tap Wipe.
  3. Now tap Format Data and continue with the formatting process. This will remove encryption as well as delete all files stored on the internal storage.
  4. Return to the previous menu and tap Advanced Wipe .
  5. Select the Cache and System partitions to be wiped and then Swipe to Wipe. *a Lineage OS guide suggested i also wipe Dalvik Cache, however i didnt do it as the /e/ instruction didnt say about it so left it.

After that

Choose “Install” from main menu.

Choose “Storage”.

choose and select the /e/ os.zip (latest version) that you copied earlier to SD micro card

i chose to tick reboot OS when done

and now swipe right to begin!

It takes awhile to install maybe about 10 mins you`ll see a bunch of text saying its installing then it will reset and have a blanks screen for while, /e/ logo which will load for for ages and then should start, and voila, a bunch of setting to configure for your new google free OS!

@freedapeoples Thanks! It worked, the OS is installed now.

Unfortunately, immediately after installing, I am getting spammed with the message “Bluetooth keeps stopping” every 2 seconds. The phone is literally unusable, I’ve tried:

  • resetting network settings
  • resetting app preferences
  • turning bluetooth scanning on and off
  • doing a factory reset
  • “Format Data” from TWRP

The error spam won’t let me turn on the WiFi either.
I found this LOS 16 install guide which says “Currently Lineage builds depend on latest 8.0 firmware (50.1.A.13.123), they will not boot up on 50.2.A.0.* or newer”. I’ll try installing older firmware via Newflasher.

Edit: I found a relevant thread on the LOS github.

Well, I’m not sure what might have caused it, but as I was rebooting after flashing stock via EMMA for the umpteenth time, the screen completely stopped working and started flashing random colors and bars. The bars kind of look like ones in the new Netflix intro. It doesn’t really stop, it just keeps going on a loop.

The phone still ‘works’ (it plays notification sounds each time I plug it in, allows me to connect it to the PC, and enter recovery/bootloader) but I can’t really do anything, as the screen is useless. I can’t tell if pressing the touchscreen even does anything.

Still, I tried entering TWRP, and seeing as how navigating via touch wasn’t an option, I tried running the recovery command in cmd to try and restore the backup I’d made previously. Sadly, as I mentioned before, adb commands don’t work while in recovery for some reason - which meant I was shit out of luck.

Although there’s a chance I might’ve screwed up something myself, I have a hunch this might’ve been a factory defect with the screen. The weird lack of recovery mode menus might also be explained by some cheap-ass manufacturing. Again, I’ve never done any Android customization before, so this is just a hunch.

Thankfully the place I bought it from has a 30-day return policy, so I’m returning it. Against my better judgement, I’m going to order the exact same model, as there’s good deal for it right now (although the possible defects might be why it’s so cheap). And also because the XA2 seems promising in regards to community support in the future.

Wish me luck with the next one, I guess. At least now I have most of the software I’ll need, along with some learning experience. But I do hope what happened with this phone really was just a one-off factory defect.

I`m sorry to hear you had problems, i dont have an Xperia phone so dont know about those bluetooth issues, however it may have been prudent to hold off before jumping ahead. I know its exciting to get started with /e/OS but the forum here specifically had u posted in the sony devices catagory may have yielded some experienced responses. Despite an issue with the firmware that you suspect you may have had, from my understanding /e/OS should work with stock phones. It maybe that your phone is indeed faulty or it could be a known issue for this phone. The forum can be useful however some people dont look at the forum every day so it may have been a few days till you get the response you need.

You should be able to restore your backup and/or old firmware with pc, from your SD card. I dont know much about this topic however your phone has to be in fastboot mode to talk to your pc and not in twrp recovery mode. the 2 modes are different ( think)…

I had the same issues with bluetooth not working messages several times yesterday when trying e and also lineageOS.

Not sure exactly how I fixed it each time, but I just had to re-install the same firmware again - doing a wipe of system again, and format data, clear cache etc.

For some reason twrp gives a /firmware access error, but then booting into the rom again, after the second install fixed the bluetooth nagging me and all worked again.

EDIT: Just had a thought, could this be related to the A/B partitions ?
EDIT 2: It is - see this post to fix: