Yahoo email settings - anyone got it working?

Hi all, I am trying to add a yahoo email account to the default email app. I have other (non Yahoo) accounts working fine, but despite searching the net and here and entering all the appropriate settings, nothing works…

Has anyone got it working? Including who was trying last year…

My settings are (as described on yahoo’s website):
*** I’ve had to replace . characters with | as 'new users aren’t allowed to add more than 2 links per post ***
Server: imap|mail|yahoo|com changed from default imap|yahoo|com (I’ve also tried mail|yahoo|com as suggested in a thread on here)
Security: SSL/TLS
Port: 993
Username: (I’ve tried just the username without the @TLD)
Auth: Normal password
Password: Well, I’ve retyped it carefully 3 times, just to be sure.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello Jack,

It was working fine on my mom /e/ phone for the last 6 months at least.
Stopped working few days ago, I don’t know why.

Something probably changed on the Yahoo side.
Maybe it’s now mandatory to use third-party app passwords for use in /e/ Mail app since it’s not Yahoo branded.
Give it a try :

I took this opportunity to migrate her away from Yahoo.

Thanks @Ceddev

That was indeed it. Here are the settings that anyone else might need (and Yes, I’m mostly off Yahoo mail, but it is there for junk mail handling).

First, give your full email address and normal password then click Manual Setup

  • Next, choose IMAP
  • Change the IMAP server to: (regardless of how your email address ends)
  • IMAP port: 993
  • IMAP TLS/SSL: yes
  • IMAP username: Your full Yahoo Mail address
  • IMAP Password Type: Normal
  • IMAP password: app password, generated from your yahoo security settings page (you’ll need it again in the next page)
  • Change the [SMTP] server to:
  • SMTP port: 465 (try 587 as an alternative)
  • SMTP TLS/SSL: yes
  • SMTP username: Your complete Yahoo Mail address
  • SMTP Password Type: Normal
  • SMTP password: the same app password used just above


1 Like

Thanks for all information.

This topic was automatically closed after 60 days. New replies are no longer allowed.