YouTube app on an eOS phone?

I have a friend that I built an eOS phone phone for and all is good but they insist to use the YouTube application. I recommend to just use the default browser, but I fall on deaf ears.

When using the app it times out after one or two minutes and does not play audio or video. Has anyone used the YouTube app with success?

Its should be noted that the user has not created their eOS account at Murena, could this be an issue preventing anonymous use?

If it is not possible to use the app on the phone, what are good alternate players of YouTube content?

Thanks, jets
Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

What about NewPipe? Works very well for me :slightly_smiling_face:


There are a few in app lounge the first one that is also open source just: NewPipe rated 9/10 for privacy?

Never mind I tried it, very nice application thanks for the great suggestion, well done :smile:

I almost never use my phone for Youtube video watching but I have LibreTube installed since NewPipe didn’t allow to search properly in some cases.


About the same for me. I don’t watch videos on the phone as an activity.
LibreTube has pushed NewPipe to backup status. LibreTube feels lighter and quicker for some reason so I use it as the main viewer to launch when following a video link. Use NewPipe as a fallback or when needing to download something.

1 Like

I myself don’t use my phone for video, when I do use my browser to get YouTube on my phone I listen to music :slight_smile:
I will look at LibreTube also.

Thanks all.

I found LibreTube in the F-Droid store will install right after my eOS update is complete.

When I started having the issue with YouTube (playback stopping after a minute or less), I tried LibreTube, since it had been working fine prior to the start of this problem. However, once the YouTube app started acting up, the LibreTube app stopped playing entirely. I could open the app, but videos wouldn’t load at all.

My wife’s FP4 had this problem from the day she got it, but mine worked fine for two months before finally showing the same behavior. Both phones were running the same OS/firmware version, and everything was set up the same between them. I don’t know what causes it.

I’ll check out this “NewPipe” I’ve been hearing about. Thanks for the suggestion.

Clear the cache of both apps. If this doesn’t help clear the entire memory of both apps (this requires making all settings new).

Clear the cache? I cleared the cache and data, and then I completely uninstalled them before reinstalling. None of that helped.

NewPipe does seem to work fine.

This topic was automatically closed after 90 days. New replies are no longer allowed.