Z5 Compact fails update

This morning notification came inviting me to update the Xperia Z5 compact (suzuran) to the latest e-0.19 version. However, after the usual download and check of the zip file the reboot into recovery failed. I tried a manual reboot into my TWRP recovery, found the downloaded file in lineageos-updates and tried to install it from there, but was told file was corrupt.

I tried deleting it and then after reboot another attempt to go through the usual update procedure but the same thing happened. So I wonder if anyone else had the same problem with the suzuran update.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @petefoth do you have this issue as reported by @Grendel with the latest build of suzuran

I didn’t have this problem but the v0.19 build for suzuran is broken (WiFi does not work - I have raised an issue) and should not have been published

For now you need to reinstall the v0.18 build

Thanks for the update @petefoth have requested Romain to remove the build.

Apologies for the inconvenience

Hi @petefoth thanks for the heads-up. As my partner uses it as her primary phone, I’ll make sure sure ignores the update notification. Thanks for all the hard work & time you put into maintaining the Xperia phones.

As I mentioned to @mihi I intend to install his unofficial build on an XZ2 compact that I recently acquired. As it has a much better camera and has a much faster CPU than the Z5 I might pass it on to my partner unless I find it better than my Oneplus 6!

This is a known issue:

A new - and hopefully functional - v0.19-q build is in progress, which may fix this issue. If it doesn’t the fix will definitely ( :wink: ) be in the first R build. In the mean time, manual install of the update in TWRP is the only option - sorry!

Presumably it will be tested to see that Wifi works! :woozy_face:

Some weeks ago, i have reading in this Forum that TWRP is actually incapable to manage updates and we have to use the LOS/e/-recovery…

That is certainly not the case for this device, nor for any of the other Sony devices I have worked with and built ROMS For (i.e. Z3, Z3 Compact, XZ1 Compact and Z5 Compact). For all thes edevcies, TWRP works fine, both for flashing updates, and for all the other things that TWRP does and /e/ or LOS recovery may not do (backup / restore, wipe, format,). Please don’t spread FUD about TWRP for these devices :slight_smile:

The “fails to update” issue is nothing to do with TWRP, and everything to do with a problem in the /e/ `v0.19-q’ build for this device.

This issue is fixed in a new suzuran dev build e-0.19-q-20211029143315-dev-suzuran.zip which will be published shortly. Unfortunately this new build will have to be updated manually, but subsequent builds should update OK using the Updater app

1 Like

The build is now available at