About to upgrade XA2 (4133) from v0.20 on Oreo (8.1.0) to ... what?

OK, so I flashed /e/ onto my XA2 just over 2 years ago (Mar 2020). It was stock Sony Android 8.1.0 before flashing. It’s been fine with OTA updates up until last Dec, v0.20-o-20211210151039. No further updates have happened since then (yes, I have the phone set to auto check daily and any manual check says “No new updates found”).

So it seems it is past time to upgrade to a new base Android version, since OTA seems to be MIA now.

Side question: why?

I’ve watched the discussion here go around on which base version of Android to flash over for initial flashing. But my question is simply this: I already have a stable /e/ 0.20 over Oreo (8.1.0) installed. Given this, is it as simple as just choosing which new base Android I want to install (P, Q or R) and just going for it? Or – and I suspect this may well be the case – are there any traps for players who last flashed a phone over 2 years ago? If so, what are they?

The documentation was not very helpful back then (I even wrote in this forum that it was better to use the SailfishOS documentation for finding drivers for the XA2 to work on Windows, then switch to the LineageOS documentation to finish up). I am hoping the documentation has been revised and tested since. I also now run from a Linux laptop so finding Windows drivers is no longer an issue.

So that’s it. I’ve been running /e/ for 25 months on a Sony XA2 (4133, dual-SIM). But, as I use this phone as my daily driver (with two numbers, one in each SIM slot), I am understandably “trepidatious” about buggering it up. Anyone done this upgrade over an existing /e/ on an XA2? Did it hurt? :wink:

Hi JJR, long time no see! I remember how confused I was with flashing the XA2 back then. Almost as confused as the people writing the flashing instructions, ha ha.

Definitely you need to return to stock Android 9 as the base for flashing any higher eOS version such as p, q or r. Whilst you would probably be able to boot you may get niggling network and other problems that others here have experienced. From a non-tech point of view it’s just kinda logical that the latest android stock firmware on device should be used.

I’ve flashed my old XA2 dozens of times with all sorts of stuff now. Currently it’s on LeOS Android 12 gsi, just for fun. Mine is single sim so can’t answer your question on dual sims with eOS.

e’s flashing instructions ae now up to date and correct. You’ll be ok following them.

Getting back to stock is easiest on Sony’s Emma flashtool, but you need Windows for that.

It’s easy flashing on Linux with Newflasher. Bit more convoluted getting the firmware with Xperifirm. It needs a bit of setting up to get it running and it’s not very intuitive I seem to recall. Happy to help if you go the Linux route.

https://xperifirm.com/tutorial/install-xperifirm-linux/

Hey, thanks for the update! Glad to see you have conquered that slightly sick feeling you get when you are about to flash – or perhaps it will be flush :wink: – a phone. I’ve never gotten over the apprehension that something could stuff it up.

Anyway, thanks again. I’ll probably do this over the next week or so as time frees up, and let you – and anyone else lurking on this topic – know how it goes… :crossed_fingers:

Hi, currently i plan to do the same. I am running v0.20-o and want to install a current R - build.

I do not mind formatting the phone, doing a fresh install without upgrade is fine. It sounds like i should install the latest Stock ROM as intermediate step.

Could you please help. Where can i download the latest XA2 Stock ROM ?

Thanks!!

Sorry, I haven’t really looked at this for weeks – got waylaid by other stuff. But have come back to look this over again.

I found a copy of the XA2 (dual SIM) Stock ROM here:

That will be my starting point when I eventually get to this. Now that /e/OS 1.0 is out, it might almost be time to do this :wink:

That’s an Android 8 rom which is the current base of your device isn’t it? Best shot would be Android 9 if you want to upgrade. It should have 50.2.A…in the numbers.

And btw Flash tool always had a bug in it that prevented successful flashing of 9 stock roms on the XA2. Maybe it got fixed, I don’t know.

Yes, currently Android 8.1.0 base under e0.20.20211210etc – no updates for 7 months.

I don’t have access to a Windows box any more, so Linux it is. I haven’t really thought about this for two years – and that was pretty much trial-and-error (as the thread shows ;-).

I guess I am going to need your help, if you’re willing to give it. Shall we take this into Messages, or do it here in public for others to see/use?

Happy to give a hand here; should be straightforward but you never know!
Most of the work is in preparing the phone and laptop (what linux distro, btw?)
Main thing is to take your time and follow a plan.

First steps (before any flashing)

  1. Get adb/fastboot on laptop, check it communicates with phone
  2. Source a rom
  3. Backup whatever you need off the phone
  4. Get newflasher, check it communicates laptop to phone

Next steps

  1. Prep phone: set usb debug, remove password (and sd card?)
  2. Prep files for flashing with Newflasher
  3. Newflasher: flash stock android 9 and boot it up
  4. Check out stock (a good time to insert sims and get APN settings for future reference)

After this, move on to thinking about eOS version to install

EDIT#1: Today I ran XperiFirm on pc and viewed roms for H4133 pioneer (pretty sure this is your phone?) and noticed that there is not a specific Aussie Android 9 rom but plenty of others. As long as it’s 9 it’s not so important which,but best to choose a “customised” version in your own language. Maybe the S.Africa.

Also today tested Newflasher v52 (links in post#2) and works ok to get stock on my xa2 H3113.

Tips for Xperifirm: Set up pc with tutorial link and download from xda link. Extract xperifirm to a folder, use the x64 version; make it executable by right clicking the file and going to properties to tick the box. Open terminal in same folder and enter command mono XperiFirm-x64.exe

1 Like

Thanks for this. I am on PureOS, a paranoid variant of Debian. The current PureOS distro Byzantium is based on Debian Bullseye.

British English works well for me :wink:

Now prepping the computer… :crossed_fingers:

OK, have gone through the process and emerged on the other side. For the benefit of others who may end up following in these footsteps (eg @forcher), here is what I did. Bear in mind this was done on a Linux machine, so there are a couple of extra steps.

In the end there were 13 steps in two main phases:
Phase 1: prepping.
Phase 2: doing.

Each step often consists of multiple sub-steps, but these can be found in the documentation. The trick is to write your own install procedure with the steps (and their sub-steps) required. Doing this makes it run much more easily.

I can’t emphasise enough how important Phase 1 is. It consisted of 8 of the 13 steps. These were:

  • Setting up a folder tree to house all the files
  • Downloading Xperifirm (with the sub-phase of getting it to run on Linux by using mono)
  • Getting the stock Android 9 ROM (I had to use the one from Brazil to get the right flavour, i.e., Pie!)
  • Getting Newflasher
  • Getting the /e/ ROM & recovery files (with SHA256 checksum)
  • Getting the copy partitions file
  • Getting the phone ready (copy files off etc)
  • Setting up adb & fastboot

Then the doing:

  • Unlocking bootloader (if required; I had already done it, but for new starters this is needed)
  • Flashing the stock Android 9 with Newflasher
  • fastbooting a custom recovery ROM
  • Making partitions consistent
  • Flashing eROM from recovery

So, how did it go? Pretty well. A couple of nerve-wracking moments after Newflashing the Stock ROM, but OK.

I’m now experimenting with the audio/mic 3.5mm jack. I’ve noticed some problems with the sound. Often choppy cutting-out sound for music, but also for phone calls. In fact, I can’t use the mic/earphone lead at all now for calls whereas I could for Oreo/8.1. Bluetooth sound seems to work OK, as does the normal speaker. I’m sure I saw someone else mention sound probs, so will go looking.

When I did this first time around 2.5 years ago, getting the Windows machine to even see see the phone was the issue. No problem under Linux, and adb/fastboot are easily got from repos.

Might need to re-flash it again and give it a few reboots under stock A9 with music to see if that fixes the mic/earphone problem, before moving on to /e/.

Again, many thanks to @chrisrg for the offline message tutorials. :+1:

UPDATE: The above was for Q, not R. Has anyone tried R and, if so, was there any issue with the headphone/mic jack for sound?

I know the jack is working because it worked flawlessly when I tested it on Stock 9 during the second re-install procedure. Perfect sound. So, the issue seems to have arisen after that with the Q ROM. Still working on it… Maybe if I just go on to R…

2 Likes

Update to the Update:

Re-flashed with R 1.0. Still has the intermittency problem with the headset jack. Tested it again while it was temporarily on the Stock Android 9: no problemo! Once R 1.0 ROM was on it, the same problem as for Q. :man_shrugging:

Bluetooth works perfectly, as before. The headset icon on the Status Bar flashes intermittently in time with the sound cutting in/out. Definitely some software glitching going on…

OTA update to latest R 1.1 ROM = same problem.

You’d be better off posting a new topic to get this issue recognised and probably don’t mention xa2 in the title. In my experience it seems to put people off, no idea why tbh. This way might get feedback to pin down whether it’s device specific or what.

Mine is still on stock. Dug some earphones out, tried music and radio, no probs, same as you.

1 Like

Will do. :+1:

Might even need to open an issue ticket on /e/Git. There are only two tagged “pioneer”, and only about 15 or so that pop up with the “Sony” search string.

Solved here: Headset produces intermittent/choppy audio after upgrade from O/P to Q or R - #6 by JJR