Headset produces intermittent/choppy audio after upgrade from O/P to Q or R

As described towards the end of this thread, an upgrade from an older version of e (8.1 Oreo) to the newest R (via a day or so on Q) has produced an issue with using the headset for listening to music, phone calls, etc. Essentially, there is rapid intermittency on sound and mic, with the headset icon flashing in the Status bar in time with the sound cutting in/out a couple of times a second.

The upgrade followed the recommended pathway of first flashing to Stock Pie, then to the final OS. I did this first for Q, then re-did it all again to R.

When the phone was on Stock Pie in each instance, there was no problem with the sound through the headset, so it is not a physical headset or phone 3.5mm jack issue. I tested this extensively while the phone was on Stock Pie, and the headset/mic combo worked perfectly.

For each instance of eOS, both Q and R, however, the headset intermittency problem emerged, essentially making the headset unusable for anything: listening to music, or making phone calls (this last is quite inconvenient since I use the headset extensively to make calls).

In all cases, Stock Pie, eQ and eR, Bluetooth headphones work perfectly with the phone.

This suggests there is an issue with the /e/ software for each of Q and R for the Sony XA2 (pioneer). It is an H4133 dual SIM.

Question is: Has anyone had this? If so, how was it resolved (if at all)?

There do not seem to be any tickets for this issue on eGit (yet).

I’ve just been playing music through headset on xa2 pioneer (h3113) and it’s fine. Eos 1.1-r. But it’s just plain headset, no microphone.

I should add that it is the headset that comes with the phone, so it is stock Sony combined earphones/mic on its “natural” “home” phone.

But, if I now try it with a no-name generic headset that does not have a built-in microphone (i.e., just plain listening-only earphones), it works!

So, it would be good if you could try yours with a mic/earphone combo to see what happens.

Yes, the jack plugs are different to allow for the additional function of mic: three insulators/separators on mic style and two on simple headset. Yesterday I ordered a cheapio replacement which will arrive on Monday.

I’ll let you know what happens.

Just thought, have you tried cleaning the jack and socket on phone?

Yes, I tried
the ol’ “cotton earbud sprayed with lens cleaner” trick.

Still getting the intermittency, though.

But I’m now wondering if there is perhaps a problem in the headset which didn’t show up when I tested it during the brief period I had the phone running on Stock Pie each time. It could just be a data sampling issue making it appear as though it is eOS that is the problem, when it might not be. If there is a broken wire in the headset lead this might explain the intermittency…


UPDATE: Well, things are always interesting with technology…

I bought a $7 cheapie earphone/mic combo, tried it, and it worked. So, I got a new “proper” $30 Sony earphone/mic set, which also works.

So, it appears as though the old headset has an intermittent fault that decided never to show up while I was testing the stock Pie install before flashing to eQ and then eR, and only to show itself – each time, mind you! – once the new eROM was running. :person_shrugging:

Sneaky technology! :wink:

Funnily enough I also use the old Sony headset for video calls on my laptop, and there has not been a problem with sound or mic. So, maybe this becomes an X file (play theme music).

Meanwhile, the inability to make calls has been solved (admittedly, by buying a new headset), so in that sense this is now a “solved” thread.