Advanced privacy disrupting location

Gigaset GS290

Upgraded to v1 and my phone keeps reverting to Advanced Privacy, no matter how I try to disable this. Advanced Privacy seems to make my location to be in the Phillipines. Tapping location just does not work. How can I permanently turn Advanced Privacy off?

Also phone cannot read or even detect my SD card.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

One thing I found, spoofed location continues its setting even when Advanced privacy is off.

I think we need to get control of location spoofing some other way.

In my experience leaving the phone alone works better than keep going round in fruitless circles, but I do not have another answer which actually resolves the issue.

Others have recommended powering off the phone and switch on (rather than just restart).

I have tried powering off and restarting several times, the problem is, even though I have turned Advanced Privacy off in settings. When the phone powers up Advanced Privacy also starts up.

I had this exact same issue too!

I seriously thought that the GPS on my phone was broken.

My post about it over on the Teracube forum:

TLDR: in Settings → Advanced Privacy → Manage my location:

Changing those settings that to “Use my real location” fixed my issue!

Hello,
I have the same location problem with the same GS 290 phone since the implimentation of Advanced Privacy a month ago. Disabling Advanced privacy does not work, neither does selecting “use my real location.” I have just upgraded the e OS to the latest version but no improvement.

This is a serious bug (for someone who needs GPS all the time like me), seeing as this is a Murena device I don’t understand why this feature was rolled out when it didn’t work yet even on these devices. Can I maybe downgrade the OS until this is stable?

1 Like

That is what I did!

With GS290 v0.23 is still available. (GS290 also seems to have a v1.1 ROM but only for stable build devices.)

Different Build Types

1 Like

I have a Gigaset gs290, advanced privacy ≥ manage my location > use real location did solve my GPS (thanks jdaviescoates). I assume you have tried a phone reboot after selecting this setting.

I have found that selecting ‘forget advanced privacy’ does not survive a reboot. My phone starts up again with a VPS operating. I agree, this function does need to be sorted out.

Is it possible to revert to previous version when a user encounters update problems or simply inconveniences?

Greetings! Thanks for this! I will have a look

One thing to take into consideration is that you will revert to older security updates, so you might not revert for a minor inconvenience.

I was uncertain of this assertion. I am now using a test build 1.1-rc.3-q-20220624199212-dev-a3xelte.

Advanced privacy is default off. Maps is working for me. Location faking is on default “Show plausible”. Device is nearly stable for 3 days.

I want to test “Real location”. With Advanced privacy still off, I toggle Manage my location from plausible to real. I see this

No, I cannot read the whole notification …

So I switch Advanced privacy on for just a few minutes, switch it off again.

So far the device is stable.

Incidentally during this I see another fleeting notification advising me that the internet may be slower with Advanced privacy on.

I don’t think that this is a bug. When location is disabled in the Advanced privacy settings, it is normal that the Maps app does not show the location.
Yes we can enable real location, but we loose the advantage of not being tracked which is one of the privacy functions that /e/ offers.
Now I wonder if location could be enabled ONLY for the Maps app… because don’t get me wrong, I would also like to see my current location on the map.

1 Like

Hi @cedricoola this is not a bug.

It was intended as an explanation.

I cannot comment on “ONLY” … but my expectation was that Maps should set up correctly … as I reported, affirmative.

Can you rephrase this sentence please? I don’t know what you mean to say, sorry.

The OP introduced the idea that “Advanced privacy disrupts location”.

So it seemed.

Primarily, this seemed to be correct on some devices. I filed an issue Testing R unofficial; Manage my location -> Real location, fails to resolve (#5622) · Issues · e / Backlog · GitLab – perhaps this was actually another issue; Advanced Privacy blocks trackers from "/e/ System".

The OP draws attention to an apparent fault. My latest post here suggests that … the situation may have been recovered.

Same problem here, I’m stuck in the Philippines :slight_smile:
Edit to say that I’m still in the Philippines even after switching off advanced privacy.

Hi @Peromato the fake location you see has been introduced by Advanced privacy > Manage my location.

An Advanced privacy widget appears on your far left home screen.

In this thread we have discussed the way that the feature may not work perfectly. It is not clear but the difficulties seem to vary by device, and perhaps other things.

Apologies @cedricoola, I feel I lost focus; I have been frustrated at this device of mine “nearly working”.

FP4 still has this problem on latest version of OS. It will never show real gps, advanced privacy keeps showing/and using the random specific generated location. Also seems no way to disable advanced privacy as a whole…

This topic was automatically closed after 31 days. New replies are no longer allowed.