AFWall+ log reveals lots of connections to Google on One Plus devices

privacy

#1

Is /e/ only boasting of degoogling our phones? Or how else can this be explained:

All of the Google services that microG would provide were disabled beforehand.


#2

Hello, the team is aware about that. But does /e/ is in stable version? No. Did you read the road map? Apparently not.
I suggest you to do the same test when the dev team will release the first stable version. Cheers,
Julien


#3

Maybe your English is not where it should be but how about just “we are still working on it” rather then scolding the user?


#4

Hi Julien, thank you for the clarification. I’ve read many of /e/s pages, but not all and have not come across a road map. I know that LineageOS has the said problem and that is why I always first install AFWall+ and AdAway before I let a phone access the net. But I was eager and hopeful from what I had read, to leave that nuisance behind by using /e/.

I will now install LinegeOS on my as of yet unused phone. Not because of these attempted connections to Google (the change would be pointless for that reason), but simply because my ‘cheeseburger’ is not useable with the current state of /e/ as it can not reproduce any sound.

Though I’ve filed an issue about that problem, it does not turn up in your list of issues. So I’m unsure if I did it the right way and have no clue when the issue might eventually be solved.

I guess, when finally /e/ and LineagOS are both at the same android version, switching between them will be no big hassle and I will give it a try. Hope you can accomplish your goals.


#5

Have a look here for a road map: https://e.foundation/mobile-phone-os/

You did it right and your issue is there. You posted your issue under the “management”-group while the other link, that you mention, shows the issues of the “wiki”-group. Since there are lots of groups, it may look a bit confusing at first. If you want to view a combined list containing the issues of all groups, then go to https://gitlab.e.foundation/groups/e/-/issues.


#6

Thanks @moose for sharing the screenshot and issue details. We have passed on the details to the development team to look into the firewall logs and provide an explanation as to why this is happening. Will update you on the progress.


#7

To add to my previous response @moose if possible please can you share the logcat from your phone i.e. if it still has /e/ on it.
As you may be aware you can get a log from the phone using adb from your PC by typing
adb logcat -d > logcat.txt


#8

You are right Andu, I apologize @moose if you have been offended by my straight behaviour.
You did the right thing to open an issue. :slight_smile:


#9

@moose in case you have removed /e/ and put in lineage, please could you check for the same scenario and share the logs… sorry for troubling you but it will be a great help to us in debugging the issue. It will be helpful to compare the behavior in the two OS and understand what is wrong and where.


#10

Sorry @Manoj, I didn’t see your answer in time. LineageOS is on the phone by now. When AFWall+ and AdAway are in place and the scenario is to be compared I will share the logs. I’d be glad to see /e/ succeed.
I try to avoid the terminal where possible. Thats why I posted the log that was produced by Logcat Reader in the first place. Shall I do it same way again or the the way that you described? I’m not aware if the output of both is comparable.


#11

Do not mind. I aknowledge that you are but a few people with a heavy workload and me too could have put in an other way.


#12

@moose please share the logs for LineageOS in the way you generated it for /e/ . We wanted to compare the logs from the two OS and debug the issue. Thanks for your time and support.


#13

@moose,

Checking the IP addresses from your logs (see summary below), application “OnePlusPocketMode” is the one connecting to Google. Since this is a device-specific App we anticipate the problem is indeed with LineageOS and you will see the same running LineageOS itself…

Anyhow good catch and thanks for reporting this issue, we definitely want to hear about such findings, and get those resolved. Topic title updated to indicate issue is applicable to One Plus phones.

OneplusPocketMode

108.177.126.96 Google LLC google.com
172.217.17.68 Google LLC google.com
185.207.104.70 netcup GmbH netcup.eu
172.217.17.38 Google LLC google.com
74.125.143.94 Google LLC google.com
173.212.196.208 Contabo GmbH Contabo.com
172.217.17.36 Google LLC google.com


#14

Hi @Patrick, good to see how you look into it!

Your answer by the way made me aware of a problem with this here page. I can see only the 7 lines of the ip addresses that concern PocketMode. In the mail receceived, there are much more (see screenshots). I’ve tried Firefox, Falkon and Epiphany, but its all the same, your text seem to be truncated when viewed here. This might cause misunderstandings …


#15

No mystery there, I updated my post to focus IP analysis to the problem statement you raised, now the email was already sent with original post content including all. No bug on that one :slight_smile:


#16

If anyone here notices that Google tries to boycot the development of an alternative, you could consider to report this to Margarethe Vestager of the EU Antitrust Commission. Or to an EU MP. Twitter: @vestager
MP: @UGambini
It is very important to let the European Commission know what Google is doing.


#17

Issue is resolved - it is possible to use both 01. and 0.2 with all hardware working now


#18

Thank you very much. This is an encouraging progress. I will keep watching the development, because my main problem is not yet resolved. Furthermore I am waiting for /e/s step to Oreo for the cheesburger too, as I hope that I then will be able to easily switch back (and forth if necessary) from Lineage-microG 15.1 to /e/. That is why installed LineageOS for microG in the first place. I do not need and use microG.

Does /e/ use the same signing keys as LineageOS for microG ??


#19

Hmm. Have you visited the issue with your my main problem recently? :slight_smile:

It is closed and resolved (see my latest comment there that references another issue with the solution). Basically the problem is firmware incompatibility. For /e/ 0.1 you need a certain version (linked there) and for /e/ 0.2 you need the latest version of firmware (lined out in the other issue in the latest comment as well).

BTW, there is /e/ 0.2 unoffical available including OTA support: Oneplus 5 (cheeseburger) /e/ 0.2 unofficial now available (Bonus: receives OTA updates)

How could /e/ sign with the keys of a different project? That would render the idea of signing useleses, wouldn’t it? :slight_smile:


#20

I’ve visited that issue often, but I did not notice that it was closed. Even now that I knew and looked for it I did not find it beeing so. I had to make my browser search for it. I guess I was too much preoccupied by the idea, that the ‘closed’ badge was a label and to be found in the right sidebar with the other labels.

As to the signing keys: /e/ is based on LineageOs an uses microG. Thats what made me think its the same combination and therefore it might be the same signing keys… :flushed: So, if I understand that thing rightly, it will not be possible to do a so called dirty flash. This makes the change of course trickier for an unexperienced user like me. I feel insecure about backing up my data that can’t be backed up using TWRP. I tried that once with an other phone but did not succeed. So I will rather wait for an official version, hoping that I can stick to it.

In order to install a recent Lineage-microG update I had to flash firmware and modem 5.1.7. I think it would be a good thing if /e/ could attach its development to the actual firmware at a time, avoiding downgrades prior to installation. I fear downgrades are normally not intended or even expected and thus might more often cause issues than upgrades.