All photos and videos are gone

Hi everyone,

today after taking a photo with my Fairphone 3 I got the error message “Failed to save photo”. When I tried to open a video I recorded on Christmas Eve I got the error message “Cannot open file”. After a restart of /e/ OS my OpenCamera folder was gone and my SD card was empty. In my /e/ cloud there is not a single photo or video of the last weeks. I am a bit shocked how that could happen as I didn’t do anything unusual.

Anyone who has an idea how I can get the photos and videos of the last weeks back? It is really important to me because it is about the photos of the first Christmas of my little daughter. Thanks a lot in advance.

Kind regards,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I can understand your worries. Did you check if you are looking at the right location? I guess yes. But please look in the settings of open camera if there is something strange.
Are you a Windows, Mac or Linux user? There are some tools for all OSs to recover files from SD cards.

So saving the files has worked before the issue? Were they visible in the gallery before the issue?

In the camera App, what is set in Settings (the cog wheel in the top right corner) - More camera controls… - Save location?
Right below that setting, is “Use Storage Access Framework” enabled or disabled?

Thanks a lot for your replies.

Yes I’m quite sure, I’m looking at the right location. In the overview of Settings - Storage it says that there are no Photos or Videos on my phone.

I’m a Windows user. I already found some tools which cost around 70€. If that’s really necessary, I’m asking myself, why I pay money for /e/ cloud.

Yes and yes.


I guess thats the folder DCIM/OpenCamera I can find in the Files-App on my SD card. That folder is empty.

It was disabled. But the error message still appears after enabling it.

You can try photorec

PhotoRec | heise Download -

This might give further hints for open source tools

Top 5 Completely Open Source Data Recovery Software for Free -

1 Like

That’s Internal Storage.
Since you are referring to it … do you use an SD card, and if so, when the OS asked, did you choose for the card to be handled as Internal Storage or as external storage?

Are you on Android 9 or Android 10? See Settings - About phone - Android version.

The combination of Android 10 and an SD card used as Internal Storage seems to be a troublesome issue currently for several Fairphone 3/3+ users.

1 Like

Thanks for your help. But I don’t know how to recover data on a connected phone with Photo Rec or any of these open source recovery tools for Windows. I can only select drives but not my phone storage for scan. As I mentioned, special tools for data recovery cost around 70€.

Thank you! Yes I do use an SD card. I don’t know what I chose, but it is shown seperately in the storage section of Android settings (apart from internal storage). There are no Pictures or Videos anymore on the internal storage either.

I’m on Android 10.

Btw: the thumbnails of the lost photos and videos are still on the SD card.

Hmmm … in earlier Android versions that would have hinted at external storage for the SD card, and that shouldn’t be an issue then, but I don’t know whether that still is the same in recent Android, let alone if Android 10 might be buggy in that regard.
I don’t have a way to test that currently.

If the SD card is external, and if the Files App doesn’t show anything in DCIM/OpenCamera in Internal Storage, I have no clue what’s going on.

If the SD card would be Internal Storage, data loss was reported by several users over at the Fairphone forum in connection with Android 10, and I have not yet seen a solution. It’s not looking good for this case as of now.

If you have a card reader for your computer, you could remove the SD card and see whether the computer can read it. In Windows this would also give you a drive letter to run photo recovery software on. But that only works if the card really was handled as external storage.

In DCIM/.thumbnails probably. But on the SD card, not in Internal Storage?
Anyway, it’s no guarantee for the files the thumbnails were made from.

I have to correct myself: it’s just the thumbnails of the videos. I found it in Movies/.thumbnails which is on the SD card.

I already tried that, the SD card isn’t recognized. I think that’s because it’s encrypted.

During my research I found out that there are Apps that enable to mount an android smartphone as Mass storage device in windows. I think that’s what I have to do, to run a recovery from my PC. There is an app called USB Mountr in the /e/ foundation app store. But that app needs root access. Knowing that it’s risky, I tried to get root access with KingoRoot, without success. Does anyone have an idea how I can grant root access for the USB Mountr app. Or is there another way how I can mount my phone as mass storage device?

Did you purchse the phone from the e foundation? If so please get in contract via first.

Did you look at the “Deleted files” in /e/ Cloud web interface ?

No, I didn’t.

I did. It’s empty.

But you purchased the cloud storage, right? So it won’t hurt to approach them.

Yes I did. 64 GB. Just 2 GB are used, yet.

I contacted them now. But I don’t have much hope that they will help me. So I would be grateful for any ideas how I can restore the data on my phone.

Ok, so it was incorporated into Internal Storage.
That’s looking rather grim then, sorry.

I don’t know of a way, but if you somehow get this to work, it would help other people, too.

A quick internet search says mounting an Android device as USB storage has been removed from Android since Android 5 Lollipop.
Supposedly there are file recovery Apps you can run on the phone, but I’m not sure they would really have the necessary low-level access to the file system without root.

Brief update in this case:
10 days ago I had the same error again as in December. When taking a picture, I got the error message “failed to save photo”. The pictures I took before were still in the gallery. I could open these pictures, zoom in these pictures (which makes me think, the data had to be still there completeley) but I couldn’t share, copy or access these pictues in any way (accessing the folder from my PC it was empty). My storage manager said, there are 0kB of images and videos on my SD card.
After changing the storage location of my OpenCamera App, I could take pictures again.
I contacted the support and explained everything many times, sent them log files and so on and told them, that the SD card can’t be defect, as I still can save and access data on it. Yesterday they asked me to access the - empty - folder via adb and now the pictures are finally gone, even from the Gallery.
I really regret, I convinced others to use this operating system and spent money on it. I’m definetly out. Good luck!

I’m very sorry for you as I can imagine that losing that data is very frustrating!
But just be warned that using the SD card as internal storage is currently strongly discouraged even when using stock OS for FP3.

So just be aware in case you’ve decided to change your installed OS…

1 Like

Thanks for that hint. In my opinion that still doesn’t explain why my photos weren’t synced to the cloud.