Android 10 works like a charm...but no streaming services anymore!?

Dears,

i update my /e/ OS with the guidance of @SuzieQ to Android 10 . thanks for that. It is simply great.

Now something strange happened. I installed all apps again and somehow, no Netflix,no Disney+ or alike work anymore!
I simply can not stream the Video. Entering the APP is no issue but as mentioned, no playback.

Never had this before or read about it so far.

Any ideas to solve this are welcome!

Best regards,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Are you connected to LTE or only 3g ?
Have you tried under WiFi ?

Hi @piero,

i used wifi and no wifi. I di not switch between LTE or 3g.

Also i would not want to do it:)
If i would not usw these two services i would not bother. This is however really strange and bothering :frowning:

I was asked if 4g is working because my ARTE.tv streaming app don’t work on 3g, and some fresh install of /e/OS are configured with 3g by default.

Interessting.

However i tried and it does not work.
I did not Change my wifi set up,nor do i use different apps.

It is realy a pity if this is now the standard.

Btw.

Disney+ Error code 39
Netflix error code 5.10

:frowning:

1 Like

Additional information i can give:

I reinstalled Netflix and Disney+ several times.
I also reinstalled the /e/ os.

Anyone having the same issue and or maybe these apps running but not an issue?

Thanks and best regards,

1 Like

I have the same issue with /e/OS ‘Q’ on my Galaxy S9 (starlte). I can’t get Netflix / Prime Video etc. to stream content. It worked previously on the /e/ Oreo build but not on Q. After some looking around it seems to be a DRM issue, but I can’t find much more info on it and no solution so far.

Any help / suggestions to fix would be great.

I have the same isse with my /e/-pie build on Galyxy A5 2017. I cannot provide a solution but at least a workaround for Netflix: I use an older version of the Netflix App (Version 3.16.3) and this version is working fine.

I tired an old version from Disney+ and that trick did not work so far.

@Manoj how are you doing?

Is this issu something that can be fixed in the next update? My xiaomi redmi 4x is working well in regards of streaming netflix, primenvideo or Disney+ with the newest /e/ update.

Thanks and best regards,

I still don’t have /e/ installed on my Galaxy S9+ so I was wondering if it supports SmartView (a.k.a. MiraCast) not Chromecast like non-Samsung devices…

There are some open issues on gitlab with specific apps which do not work on /e/. The developers are looking into it but do not have any ETA’s as yet.

2 Likes

Thanks for the info!
Much appreciated.

Just to confirm, the streaming apps i refered too are running fine in other non Samsung devices after the New /e/ update.

I flashed the Official Samsung “Three Ireland” Android 10 firmware as a base before installing the new /e/ Q OS and am experiencing the same problem. I wonder is there a known firmware version that does not have these issues that could be used as a base to install /e/ over?

I’m not too familiar with this stuff so maybe I’m way off, but it seems to be vendor/model specific so my assumption is there is something in the official firmware that is blocking this. Perhaps there are some versions that don’t block DRM content.

My firmware which does have this issue:

Model SM-G960F
Model name Galaxy S9
Country Ireland(Three)(3IE)
Version Android 10
Changelist 19869059
Build date Thu, 17 Dec 2020 05:22:15 +0000
Security Patch Level 2021-01-01
Product code 3IE
PDA G960FXXSDFTL1
CSC G960FCKHDFTL1

That would be an interesting aspect.

When I flashed the stock ROM of Samsung for Germany I did find two versions online which I could not distinguish as both have been for the sm g 960f/ds. Hence I simply chose one:)

Anyhow ,if this might really be connected with one firmware somehow working, would actually another 960f/D’s version from within Europe work also for me?!?

For me it is still prime,Netflix and Disney not working.

1 Like

I do not want to be impatient, but as the galaxy s9 with e os is actually my main phone, i am eager to learn if anyone else has this issue of not being able to stream Netflix,prime and or Disney+.
I will reinstall the ROM if needed but I would like to learn beforehand if this might help at all.

Thanks and regards,

I’m in the same situation and unfortunately not being able to stream from these services is kind of a deal breaker for me sticking with /e/ for now. I’ve re-installed the stock ROM :pensive: but plan to re-install /e/ once a fix for this appears.

I purchased an S9 SM-960F here and I absolutely want to upgrade above android 8.1.0. This is one of the only threads I’ve seen that explains why I’ve been discouraged from upgrading.

Apparently I need to downgrade to stock before I can get to Q. Does that mean I need the French version? Where do I even get a stock rom from?

It’s all starting to sound the same. That is to say what I’m reading is ambiguous and full of caveats.